[Techtalk] Unreadable(?) pdf files
david at aeolia.co.uk
Sat Mar 12 22:00:28 UTC 2016
On Sat, 2016-03-12 at 14:02 -0700, Akkana Peck wrote:
> David Sumbler writes:
> > All of them installed without difficulty apart from one:
> > 'sudo apt-get install liblcms2-dev' produces the following error
> > message:
> > ***
> > Some packages could not be installed. This may mean that you have
> > requested an impossible situation or if you are using the unstable
> > distribution that some required packages have not yet been created
> > or been moved out of Incoming.
> > The following information may help resolve the situation:
> > The following packages have unmet dependencies.
> > liblcms2-dev : Depends: liblcms2-2 (= 2.2+git20110628-2ubuntu3.1) but
> > 2.4-0ubuntu3.1~precise1~ppa1 is to be installed
> > E: Unable to correct problems, you have held broken packages.
> > ***
> > I do not understand this message, nor what I should do about it.
> Sometimes using aptitude rather than apt-get can help with this sort
> of problem. Try: sudo aptitude install liblcms2-dev
> Sometimes it will give you the dependency error, and then give
> you a list of things it can try, e.g. removing the liblcms2 you have
> and installing a different one (and maybe adjusting a few other
> packages too). It will ask, "Accept this solution?" If you don't
> accept it (perhaps because it removes something you depend on),
> you can say n and sometimes aptitude will offer a few other
> solutions, and one of them might work.
> But I'm a bit doubtful, looking at the versions of those packages.
> 2.2+git20110628-2ubuntu3.1 has "git" in the version, which sounds
> like it's meant to come from a repository tracking lcms's git
> master instead of Ubuntu's regular repositories.
> 2.4-0ubuntu3.1~precise1~ppa1 also makes me wonder, because I don't
> remember seeing things like "ppa1" in Ubuntu versions (but I don't
> have an Ubuntu running right now to check that), so I wonder if
> that might be coming from a different nonstandard repository.
> (A PPA, "Personal Package Archive", is like a mini-repository
> anyone can set up to distribute software, usually for distributing
> packages to Ubuntu users that are newer than what Ubuntu provides.)
> Try this: apt-cache policy liblcms2-2 liblcms2-dev
> That will tell you what repository those two packages come from
> by default. If they aren't coming from standard Ubuntu repositories,
> and if they're not coming from the same repository, that's why
> apt-get is complaining. There are ways of fixing that, but it
> depends on why those repositories are there (they're probably
> specified in /etc/apt/sources.list or /etc/apt/sources.list.d/*).
Thank you for this helpful advice.
'apt-cache policy liblcms2-2 liblcms2-de' did not seem to show any
potential problems, so I tried 'sudo aptitude install liblcms2-dev' as
you suggested and accepted a solution which involved downgrading
'python setup.py build' then ran without errors, and so did 'python
Unfortunately, although sK1 started OK, on each occasion when I tried to
open a .cdr (CorelDraw) file it crashed the computer. And sK1 would not
open the .pdf versions at all.
However, plan 'B' might work after all! I have discovered that my
sister-in-law is using an ancient machine that has a floppy drive. It
also has a USB port, so when I visit my brother this coming Wednesday I
should be able to copy all the .eps files I have (on 19 3-1/2" floppies)
to a memory stick.
The .eps files are the files that the .cdr and .pdf files were derived
from nearly 20 years ago.
It remains to be seen, of course, whether I can actually open these
More information about the Techtalk