[Techtalk] Unreadable(?) pdf files
akkana at shallowsky.com
Sat Mar 12 21:02:57 UTC 2016
David Sumbler writes:
> All of them installed without difficulty apart from one:
> 'sudo apt-get install liblcms2-dev' produces the following error
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help resolve the situation:
> The following packages have unmet dependencies.
> liblcms2-dev : Depends: liblcms2-2 (= 2.2+git20110628-2ubuntu3.1) but
> 2.4-0ubuntu3.1~precise1~ppa1 is to be installed
> E: Unable to correct problems, you have held broken packages.
> I do not understand this message, nor what I should do about it.
Sometimes using aptitude rather than apt-get can help with this sort
of problem. Try: sudo aptitude install liblcms2-dev
Sometimes it will give you the dependency error, and then give
you a list of things it can try, e.g. removing the liblcms2 you have
and installing a different one (and maybe adjusting a few other
packages too). It will ask, "Accept this solution?" If you don't
accept it (perhaps because it removes something you depend on),
you can say n and sometimes aptitude will offer a few other
solutions, and one of them might work.
But I'm a bit doubtful, looking at the versions of those packages.
2.2+git20110628-2ubuntu3.1 has "git" in the version, which sounds
like it's meant to come from a repository tracking lcms's git
master instead of Ubuntu's regular repositories.
2.4-0ubuntu3.1~precise1~ppa1 also makes me wonder, because I don't
remember seeing things like "ppa1" in Ubuntu versions (but I don't
have an Ubuntu running right now to check that), so I wonder if
that might be coming from a different nonstandard repository.
(A PPA, "Personal Package Archive", is like a mini-repository
anyone can set up to distribute software, usually for distributing
packages to Ubuntu users that are newer than what Ubuntu provides.)
Try this: apt-cache policy liblcms2-2 liblcms2-dev
That will tell you what repository those two packages come from
by default. If they aren't coming from standard Ubuntu repositories,
and if they're not coming from the same repository, that's why
apt-get is complaining. There are ways of fixing that, but it
depends on why those repositories are there (they're probably
specified in /etc/apt/sources.list or /etc/apt/sources.list.d/*).
More information about the Techtalk