[Techtalk] zoneminder, motion fail on ubuntu 13.10, no /dev/video0

Rudy Zijlstra rudy at grumpydevil.homelinux.org
Sun Feb 2 20:55:43 UTC 2014

Hi Carla,

The /dev/video0 will only be used by a local connected (USB) webcam. For 
the IP based webcam, the config of the tools (zoneminder, Motion) needs 
to point to a URL.
The bug might be that the ubuntu build does not support remote webcam?

Not using Ubuntu, so cannot test



On 02-02-14 21:50, Carla Schroder wrote:
> I'm nearly certain that the key here is the missing /dev/video0. Does
> anyone know how Ubuntu 13.10 creates it? On my older Mint system (based
> on Ubuntu 12.04) it is created at boot, so it is always available. I
> have no idea how 13.10 handles this, other than poorly. Is this my
> welcome to the fun new ever-encroaching world of Upstart?
> This is how I created it manually:
> mknod /dev/video0 c 81 0
> NFI why that doesn't make buntu happy.
> Carla
> On Sun, 2 Feb 2014 11:31:36 -0800
> Carla Schroder <carla at bratgrrl.com> wrote:
>> hey all,
>> I swear the more I use computers the more I swear at them. I have a
>> Foscam FI8905W wireless IP camera.
>> Just a nice outdoor cam with its own embedded Web server and wifi so I
>> can spy on my driveway from any Web browser.
>> Theoretically.
>> I can log in directly to the Foscam via Web browser, see the live
>> stream, and access the admin panel from any of my computers and
>> smartphones. Easy peasey.
>> So the next step is to set up Zoneminder or Motion for recording and
>> alerts. There is something batshit screwy with Ubuntu 13.10-- I have
>> an old Linux Mint 13 installation, and with both Zoneminder and Motion
>> it's ten minutes from installation to viewing the live stream from the
>> camera in a browser. But not Ubuntu 13.10.
>> Motion gives the error message 'Failed to open video
>> device /dev/video0: No such file or directory' So I
>> created /dev/video0 with good old mknod. Same error message. So I
>> deleted the dratted thing.
>> I can plug in a USB webcam, which creates /dev/video0, and then Motion
>> picks up the webcam images. (Cheese and luvcview also display the
>> webcam stream.) But still no live view, only a series of jpgs in /tmp.
>> Naturally the motion, Zoneminder, and Ubuntu forums are full of sad
>> posts with the same problem, but no solution. I'm not even sure where
>> to start troubleshooting. Bright ideas anyone? Besides going on a
>> killing spree until all computers are eradicated and we can live happy
>> and free in an agrarian paradise?
>> Carla

More information about the Techtalk mailing list