[Techtalk] Thinkpad/Debian

Patricia Fraser trish at thefrasers.org
Fri Sep 14 14:56:38 UTC 2007

Hash: SHA1

Hi folks,

hoping you can help. I've got Debian Etch installed on two Thinkpads -
my own (this one), a T30, and my daughter's, a T41. The T30 has a dud
internal aironet wireless card - it's there, but it don't really work
too well (probably since I changed the fan and did it a damage). The
T41 has the Intel 2100 internal wireless card.

In the case of the T30, the airo module is loaded at boot time, and the
iwlist command will scan networks, which I can see - all without there
being any entry in /etc/interfaces. If I run ifconfig, I see three
interfaces - eth0, eth1 and lo. If I look in /proc/driver/, there's a
directory airo, with another, eth0, below it.

However, on the T41, although lsmod shows the ipw2100 driver is loaded,
the machine doesn't see any card, and no device is set up. Again,
there's no entry in /etc/interfaces, and if I run ifconfig, there's
only eth0 and lo. There's nothing showing up under /proc/driver/.

I've looked through the Debian docs, through thinkwiki and googled, but
nothing shows me how, or where, the T30 is setting up the eth1
interface (actually, it's the eth0 interface); or what I can do on the
T41 to get it seeing the wireless card.

Anyone got any suggestions, pointers or good places to look? Is it as
simple as putting something in /etc/modules and an entry
in /etc/network/interfaces?


- -- 
Trish Fraser, GWQTF RP4GD
vr sep 14 15:28:57 BST 2007
GNU/Linux 1997-2007 #283226 counter.li.org
pegasus up 7 hour(s), 2 min, 40 sec
kernel 2.6.18-4-686
- --
Version: GnuPG v1.4.6 (GNU/Linux)


More information about the Techtalk mailing list