[Techtalk] jpilot on Ubuntu 7.04, Palm IIIxe, serial (ttyS0) connection, or use something else?

Deborah Gronke Bennett deborah at deborah.best.vwh.net
Tue Oct 16 23:39:45 UTC 2007

Hi. I'm new to the list, and I hope this posting fits the guidelines 
I've read.

I am rather an experienced UNIX user, and I have been using Linux for 
many years now. However, this problem has me stumped and frustrated.

I have been using jpilot and my Palm IIIxe to keep track of names, 
addresses and phone numbers. I normally keep the Palm Pilot in my purse 
to use when I'm away from home, and run jpilot on my linux laptop at 
home. To sync them up, I connect the Palm to the laptop with the serial 
cradle (/dev/ttyS0).  This setup worked fine for me until I upgraded to 
RedHat core 4. I had lots of trouble getting jpilot to contact the Palm 
Pilot through the cradle to do a sync. There were a collection of 
problems around getting /dev/pilot to point to /dev/ttyS0, and to get 
the correct permissions on the devices. I resorted to a small shell 
script which I ran every time before I synced the pilot. Here it is:

#Set up /dev/pilot so Jpilot sync will work

echo "Setting up /dev/pilot"

set -x
ln -s /dev/ttyS0 /dev/pilot
touch /dev/pilot
echo "hello" > /dev/pilot

Sometime this summer I upgraded to Ubuntu 7.04. I haven't been able to 
sync the Palm Pilot since. I've spent a bunch of time googling and 
trying various solutions I found out on the Web, with no luck.

I know my Palm Pilot and the serial port can communicate, since I can 
make pilot-xfer work. I put my Palm Pilot into the cradle connected to 
the serial port. I run pilot-xfer through /dev/ttyS0 to list all apps:

 pilot-xfer -p /dev/ttyS0 -l

I press the hot-sync button on the pilot cradle, I get the starting 
beeps, then the terminal window shows:

   Listening for incoming connection on /dev/ttyS0... connected!

   Reading list of databases in RAM...
(list truncated for brevity)
   List complete. 39 files found.

   Thank you for using pilot-link.

And then I hear the finishing beeps from the Pilot.

Yesterday I spent a few hours downloading gnome-pilot. It works, but all 
it does is download all the databases - there is no application I can 
find to edit the databases on the PC side. Then I tried downloading 
kpilot. It didn't interact well with gpilotd (the daemon from gpilot). 
When I paused the gpilotd daemon, kpilot just hangs attempting to do a 
first full sync before it will let me do anything else.

So now at the end of this long ramble, I'm wondering what my best 
approach is. I would be happy to continue to use jpilot if I could get 
the sync function to work on Ubuntu. Or should I switch to another PIM 
program? gpilot only has conduits to Evolution, which I don't use. I'm 
just not familiar with any other Linux PIM suites so I don't know where 
to start looking. And I'm not sure I need a full PIM - all I use is the 
name/address/phone number functions. (I don't keep an electronic 
schedule, or to-do lists or any of that other stuff).

Thanks for listening,
-deborah bennett

More information about the Techtalk mailing list