[Techtalk] About to go insane over Modem Problem

PCasper sylph at cyber-dyne.com
Sun Oct 19 21:29:48 EST 2003

perimorph wrote:

>On Sun, 2003-10-19 at 14:57, PCasper wrote:
>>I've gotten Debian installed... haven't touched the firewall yet 
>>it won't find my modem.
>The only thing I can think of that you haven't tried is going into your
>BIOS and seeing if there's a "PnP OS" setting.  I have Award BIOS which
>has that option, don't know about others..  Setting it to No will tell
>the BIOS to assign IRQs and COMs instead of the OS doing it.  Might
>help, might not..
Hmmm. Good thought. Sadly, I was already set to No. SO I switched it to 
yes to see if  it made a difference. None.

>You might also look at the modem and see if there's a jumper where you
>can turn off PnP and set the IRQ and COM manually, but there probably
>wouldn't be one unless your modem is fairly old.
Hmm. It is a couple of years old, but I think it's still the current USR 
Controllerless Modem available. I'll take a look at the documentation.

Other details, in case they trigger a brainstorm for someone....

Realized at some point that, although I had recompiled and installed a 
new kernel with support for other serial ports, I hadn't modified my 
Grub menu to include it.... did that, tested, and got the same 
results... except a scan of dmesg shows that ttyS04 is detecting with 
the settings for my modem.... however, once I get into a terminal where 
I can check setserial, it told me I didn't have a ttyS04 in /dev. Fixed 
that with mknod, and now it's reading ttyS04 as 0x03f8 and IRQ 4, just 
like ttyS0. Have tried tweaking manually with setserial, have skimmed 
through init.d to see if there's anything which might be changing the 
serial port settings ... setserial does run from there, but it calls on 
/etc/serial.conf which I've edited manually and disabled Autoconfig for, 
so it should be taking my manual settings.

Oh, and /proc/tty/driver/serial shows 4 as the serial port number, not 
04. Has the correct settings though. Again, setting up ttyS4, like 
setting up ttyS04, sets the port to default COM port settings instead of 
pulling from the modem.

Have also installed minicom so I can test with something other than just 
pppd and chat.

About it.... gonna take myself a gander over to debian.org as well, see 
if there's any place there I can search and/or ask for help on this, too.



More information about the Techtalk mailing list