[Techtalk] About to go insane over Modem Problem

TechChiq techchiq at hotpop.com
Sun Oct 19 22:03:54 EST 2003

On Sun, 2003-10-19 at 14:57, PCasper wrote:
> I've gotten Debian installed... haven't touched the firewall yet 
> because.....
> it won't find my modem.
> Modem worked fine in Mandrake, although it  did so by curling up and 
> purring happily on /dev/ttyS5, which seemed strange to me, but it 
> worked, so I wasn't going to argue.
> Debian doesn't install /dev/ttyS5.
> I've tried using setserial to convince my modem that /dev/ttyS2 or 3 
> would be good... after all, windows thinks the modem is on COM3, which 
> should be /dev/ttyS2 in linux.
> No worky
> Modem is a USR Performance Pro internal PCI. It's a hardware modem. 98% 
> of the "configuring modem" sites I find through Google assume you're 
> starting with a WinModem. I'm not.

Sounds like you did a lot to try and get it working. It also sounds like
it's "stuck" on ttyS5. Go into the case and see if there are jumpers on
the modem you can set to change the serial port it uses. Some have it
some don't. I have a USRobotics 5687 ISA hardware modem and it parked on
ttyS2 immediately and Linux works on it from there. Is there a special
extra package that comes with Debian that would add extra "virtual
terminals" or tty devices? Might need to install that to get this to
work, it sounds like. As for finding the port addresses, I don't know
any incantations to that. However, if you have the manual or if it came
with a CD the CD might have a PDF manual on it - maybe it might have
specs in there that might have that info on it.

Linux User # 331707 Machine # 216034 (http://counter.li.org)
Pink Tie 9 (RH9 clone), Kernel 2.4.20-6, KDE 3.1, Wine 20031016
Win98SE (dual-boot)

More information about the Techtalk mailing list