[Techtalk] Re: I lost my filessystem

Conor Daly conor.daly at oceanfree.net
Tue Apr 15 12:27:45 EST 2003

On Tue, Apr 15, 2003 at 09:02:27AM +0200 or so it is rumoured hereabouts, 
Hanlie Pretorius thought:
> Hi,
> You guys are great and I was very excited to try your suggestions.
> Unfortunately none of them worked, and I give the details below (in the
> order that I tried the solutions). I would be very grateful if someone could
> try and help me again.
> 1. Carla's suggestion: booting from GRUB's command line
> -------------------------------------------------------
> The first command went fine - it found the root. But it couldn't find any
> vmlinuz* files. I found this strange because when I boot into rescue mode, I
> can see the system loading a vmlinuz file. I got the vmlinuz version from
> the GRUB commands (vmlinuz-2.4.18-14) and tried it directly (without using
> tab-completion), but it still didin't work. I got "Error 15: File not
> found", so I couldn't go ahead with this solution.

Try again but use the tab completion this time.  You'll see quick enough
either that the file isn't there or that it has a different name.  When
you boot into rescue mode, are you booting from a CD rather than from the
hard disk?  If so, the vmlinuz that is loading comes off the CD.
What is /dev/hdb1?  Is it a small /boot partition?  If so, that's where
your vmlinuz is.  I'm not sure how to tell grub that vmlinuz is in a
partition other than the root partition.  Carla?  

kernel (hd1,0)/vmlinuz... root=/dev/hdb2?

> 2. Robyn's suggestion: upgrading Linux
> --------------------------------------
> I got the following error when it was about to start the upgrade:"Error
> mounting device hda3 as /mnt/oulinux: Invalid argument. This most likely
> means that this partition has not been formatted. Press OK to reboot your
> system".

I'm not sure here, but the upgrade process is probably reading your
/etc/fstab and assuming it is to use /dev/hda3.  This seems kinda odd
since it is probably reading the fstab from /dev/hdb2 so it should pick up
on than instead.  You could at this point, do <CTRL><ALT><F3> (or is that
<F2>?) where you should be in a shell.  Then try the following:

# cd /mnt
# mkdir myroot
# mount /dev/hdb2 /mnt/myroot
# vi /mnt/myroot/etc/fstab
   do the fstab edits here
  (Be explicit about partition devices here
   rather than using labels.  Ie. replace
   "Label=/" with "/dev/hdb2")

If you can't get a shell this way, booting from a rescue CD will get you
to the point where you can do the above.

Conor (who could do it with LILO...) <ducks>
Conor Daly <conor.daly at oceanfree.net>

Domestic Sysadmin :-)
 11:58am  up 25 days, 17:34,  0 users,  load average: 0.00, 0.00, 0.00
 11:57am  up 25 days, 17:32,  1 user,  load average: 0.00, 0.01, 0.00

More information about the Techtalk mailing list