[Techtalk] Re: I lost my filessystem

Hanlie Pretorius hpretorius at pnp.co.za
Tue Apr 15 09:02:27 EST 2003


You guys are great and I was very excited to try your suggestions.
Unfortunately none of them worked, and I give the details below (in the
order that I tried the solutions). I would be very grateful if someone could
try and help me again.

1. Carla's suggestion: booting from GRUB's command line
The first command went fine - it found the root. But it couldn't find any
vmlinuz* files. I found this strange because when I boot into rescue mode, I
can see the system loading a vmlinuz file. I got the vmlinuz version from
the GRUB commands (vmlinuz-2.4.18-14) and tried it directly (without using
tab-completion), but it still didin't work. I got "Error 15: File not
found", so I couldn't go ahead with this solution.

I had a look at the GRUB manual for which you posted a link, but I couldn't
find anything that would help me, given that I understood very little of
what I read ;-)

2. Robyn's suggestion: upgrading Linux
I got the following error when it was about to start the upgrade:"Error
mounting device hda3 as /mnt/oulinux: Invalid argument. This most likely
means that this partition has not been formatted. Press OK to reboot your
When I reboot, the whole sequence repeats. Hda3 was part of my old linux
installion, over which I extended my Windows parition.

3. Robyn's suggestion: console command chroot
I got the following error when I tried this:"Cannot find kernel image

4. Robyn's suggestion: fdisk
I have a Win2k emergency repair disk, but when I try booting from it, GRUB
intervenes and complains that it's not a system disk.

I probably sound very illiterate, but at least this would be a great
learning experience if I manage to fix my installation (with you guys'

Once again, thank you for the help so far.

(Who lives in South Africa and only gets to try your solutions the next day)

More information about the Techtalk mailing list