[Techtalk] Error installing the driver of my 10/100MB Ethernet card

Magni Onsoien magnio+lc-techtalk at pvv.ntnu.no
Fri Nov 8 11:41:40 EST 2002

On Thu, Nov 07, 2002 at 07:54:40PM -0800, Samer Yhya said:
> The card
> I have is Sweex PCI LANCARD (NOT the one with wake
> on LAN). The driver is downloaded from the
> manufacturer at:
> http://www.sweex.com/product.asp?pid=106&s=2
> They claim it worked on RedHat 7.1/7.2 (and also
> Mandrake 8.0/8.1, Slackware 8.0, SuSe 7.2, RedFlag
> 2.4, Caldera 3.0). Naturally the manufacturer was the
> first place I e-mailed, but I got no response.

I don't know this card and I don't know why you get errors when
compiling the driver. But at least the driver is mtd80x, written by
Donald Becker. From a Danish site I found
(http://intern.aub.dk/support/hardware/surecom.htm, at the end) it looks
like this driver exists under different names: mtd80x, fealnx and
myson803. Check if any of these are available in your distro (my RH 7.3
has the fealnx-driver) - "insmod fealnx.o" (or "lsmod <drivername> if
you get an error that make you suspect that the driver is already

However, from what you wrote in your first post you computer seems to 
have recognized it and you should then not have to compile the module
yourself. Have you tried simply configuring it - i.e. assigning an 
IP-address and all that?

Magni :)
sash is very good for you.

More information about the Techtalk mailing list