[Techtalk] Window manager help!!

hobbit at aloss.ukuu.org.uk hobbit at aloss.ukuu.org.uk
Thu Aug 8 10:50:25 EST 2002

On Wed, Aug 07, 2002 at 08:04:59PM -0600 or thereabouts, mc wrote:
> Hi all!  I have been lurking for quite a while here, and have learned a 
> lot, thanks for that!!
> Now I need a bit of help.  For some reason tonight, both my Linux machines 
> (Dell inspiron laptop running RH7.1 and home built PC running RH 7.3) have 
> decided to go kerblooey on me.
> The symptoms on both were sort of the same, though were they ended up was 
> different.  Basically the mouse went crazy, clicking things as I moved it, 
> opening and closing things.  On the PC, I just reinstalled RH 7.3 (it was 
> only a week old and not yet totally set up)

And it's still doing mad clicky things? My first reaction would be
to take the mouse apart and clean it. Seriously.

Second, I know some mice have a little switch you can toggle between
two settings on the base somewhere. I never remember what it's for.

> On the laptop, I tried to fix it and killed it even more.  I somehow seem 
> to have lost sawfish.  I guess I figured the mouse thing was WM related so 
> I tried changing to tvm.  When I tried to change back, I couldn't (and 
> still can't get sawfish back.
> Is there a conf file somewhere that I can set sawfish to work again?  I had 
> it pretty nicely customized to my needs :)

"seem to have lost"? 

If you have no titlebars and edges to your windows, you probably
have no window manager. If you have titlebars and edges, you have
one: you just have to work out which :) "ps aux" will tell you 
everything running, but it's gigantic. You usually have to do 
"ps aux | grep thing-to-look-for" and see whether it shows up.

"pstree" is also handy if you have it: it's a tree and you can 
scroll up and down it. That should at least tell you what's

Your sawfish preferences will be in ~/.sawfish/ or ~/.sawfishrc.
I don't use sawfish, so I forget. You could make a copy of that
somewhere safe. 

The control-center program (gnomecc on RH 7.3 I think: it's 
changed for later versions of Gnome) should let you change 
window managers, but I always crash it repeatedly whilst
doing this. Try a couple of times.

If that doesn't work, make sure you know exactly where the sawfish
binary lives. Find out what window manager you're running now.
Get mouse focus on a gnome-terminal. And kill the current window
manager and type "sawfish" or "/usr/bin/sawfish" or whatever in
the window. Sawfish _should_ start.

If a big "warning, you are about to kill" dialogue pops up in
twm (or whatever) and switches your focus or obscures the
terminal you're typing in, you may have more trouble typing in
the terminal, which is why I mention focus :) 

But that should work. Then you want to save the session, either
via the control-centre or the quit-Gnome dialogue (I forget 
where it is on RH) or just by typing "save-session" into a 

In theory you'll get it starting the next time you start Gnome
then, too. Let us know if it works.

> The second question is why is the mouse still kerblooey on the PC, even 
> after the reinstall of RH?  I tried both generic 3 button and Microsoft 
> intellimouse (it is an MS trackball).  The intellimouse was working quite 
> well prior to tonight.

You tried plugging them in, or telling the box that it was using
those types? Different mice require different settings. If you 
actually reboot between different mice, kudzu (the hardware
detector) should pop up and notice. Failing that, you may have
to investigate /usr/sbin/mouseconfig or whatever it's called 
these days. It is a command-line mouse set-up tool. It has a
man page (thankfully). 


More information about the Techtalk mailing list