[Techtalk] apt-get failure

adric adric at adric.net
Sat Oct 6 13:44:55 EST 2001

Try dpkg --configure modutils
or even dpkg-reconfigure modutils ?

I haven't had a kernel image work with woody/sid yet :(
All sorts of nonsense about initrd's and no images with klips..


At 1:20 PM -0400 10/6/01, David Merrill wrote:
>I was installing the new kernel on debian sid, and got this error:
>Setting up modutils (2.4.10-1) ...
>depmod: Unexpected value (20) in 
>'/lib/modules/2.4.9-k6/kernel/drivers/ieee1394/sbp2.o' for 
>	It is likely that the kernel structure has changed, if so then
>	you probably need a new version of modutils to handle this kernel.
>	Check linux/Documentation/Changes.
>dpkg: error processing modutils (--configure):
>  subprocess post-installation script returned error exit status 255
>dpkg: dependency problems prevent configuration of kernel-image-2.4.10-k6:
>  kernel-image-2.4.10-k6 depends on modutils (>= 2.3.12); however:
>   Package modutils is not configured yet.
>dpkg: error processing kernel-image-2.4.10-k6 (--configure):
>  dependency problems - leaving unconfigured
>Errors were encountered while processing:
>  modutils
>  kernel-image-2.4.10-k6
>I get the same error when I run `dpkg --configure --pending'.
>Does anyone know how I can recover from this, or what is going on?
>Dr. David C. Merrill                     http://www.lupercalia.net
>Linux Documentation Project                   david at lupercalia.net
>Collection Editor & Coordinator            http://www.linuxdoc.org
>I have a nice perspective on what it means to be in charge of the most
>important project in the history of mankind.
>	--Microsoft project manager Brian Valentine,
>	  as quoted in BusinessWeek 02.22.99
>Techtalk mailing list
>Techtalk at linuxchix.org

More information about the Techtalk mailing list