[Techtalk] Build it! redux, and AMD woes

Akkana akkana at shallowsky.com
Sat Nov 10 17:49:56 EST 2001

Thanks so much for all the suggestions!

Interestingly, I think now that the problem was actually something
in the IDE system.  I swapped in a working floppy drive, and now
the system boots *much* faster (it used to idle for 3-20 seconds
at each boot looking for IDE drives; now that part goes so fast
I can't read the text before it clears the screen) and my two
mozilla builds since then have completed without error.

I still don't understand why a bad floppy drive would result in
specific processes dying at random places; but so far, so good.
I'll definitely check out the memory test procedures you've
recommended to me, and keep the other suggestions at hand in
case the problem comes back.

Almut Behrens writes:
> I'll definitely second that. gcc seems to be a reliable memory tester :)
> I can't exactly tell why, but practical experience shows that, when
> there's a memory problem, gcc always is the first program to throw
> weird error messages (or segfault or hang), while other programs still
> seem to run smoothly. (It's probably because it makes extensive use of
> memory to build up delicate data structures which react a bit allergic
> to external modification...)

Big builds also visit a lot of files repeatedly, which trigger Linux'
ramdisk caching and ends up using up most of the available memory
in a way that normal processes probably don't.

> PS: which kernel are you using?  I've heard faint rumours that with the
> most recent kernel(s) there may be a subtle bug in memory management

I'm still on the stock RH 7.1 kernel, 2.4.2-2.  I have a 2.4.14
downloaded for this system but haven't unpacked and built it yet
(was waiting to solve the hardware problem).  I'll keep that suggestion
in mind, though, and if I run into weird problems on the new kernel
I'll retest with the standard one before jumping to conclusions.
I hadn't heard anything bad yet about 2.4.14 ...  I'm hoping it has
all the USB patches up to date that apparently got so backed up in
the .14 pre-releases.

Adriana Gonzalez writes:
> Take a look at http://www.bitwizard.nl/sig11/

Ironic -- that was the document that solved my problem with my previous
desktop machine, which started life as an AMD K62/400 and also couldn't
compile mozilla.  Eventually I fumbled my way to the Sig11 FAQ (took a
while to find it because I wasn't actually getting sig 11 as far as I
could tell) and found out that the K62/400 was specifically mentioned
in the list of processors most likely to exhibit the bug.  And sure
enough, replacing it with a 550 solved the problem.  Yet I hadn't even
though that the FAQ might have useful information for diagnosing my
latest problem, so thanks for the reminder!


More information about the Techtalk mailing list