[Techtalk] XF86 Upgrade Woes

Telsa Gwynne hobbit at aloss.ukuu.org.uk
Sat Aug 18 10:34:37 EST 2001

On Sat, Aug 18, 2001 at 09:04:12AM +0200 or thereabouts, Rebecca J. Walter wrote:
> > Here is the error message I am getting when I attempt to log in as 
> > a regular user:
> > 
> > authentication failed - cannot start x server
> > perhaps you do not have console ownership? xinit: server error
> > 
> > I tried making a new user called test to find out if a new user 
> > would be able to start x server.  When I tried to startx from this 
> > user account, I received these errors:
> > 
> > Xauth: creating new authority file /home/test/.Xauthority
> > xinit: no such file or directory (errno2): unable to connect to x server
> > xinit: no such process (errno 3) server error
> > 
> > I found the files named ./Xauthority, but they seemed useless to the
> > situation.  Does anyone know what the remedy to this problem is?
> I remember reading something about this somewhere.  I know there are
> licensing issues with nVidia... first check ownership or stuff to make
> sure generic users can access all graphics related stuff.  other than
> that... search the web for nVidia and linux.  i know there is some kind
> of weird issue with nVidia drivers, I just don't remember what it is or
> how to fix it.  Nor can I remember exactly where I read it.
> good luck!

The issue you're probably remembering is that nvidia won't release
specs that help people write good free drivers. There are now free
drivers, although I think they may not do all the fancy stuff. But 
nvidia used to release binary-only drivers. Some kernel hackers
would get as far as "...and I have the nvidia drivers.." and either
delete or reply "remove them, then see whether the crash happens
again". I think I heard some X hackers had a similar approach.

I don't think that's the problem here, but I have no clue what it
might be. It doesn't help that I deleted the earlier messages so
have forgotten all the context. One place to start looking is 
http://www.xfree96.org's mailing list archives, particularly the 
newbie one: http://www.xfree86.org/mailman/listinfo/newbie

However, whilst I had a quick hunt through this month's archives
and found plenty of nvidia problems, I didn't find any errors 
messages which matched. However, googling on the first line of
the error message helped a bit: people who got that error nailed 
it down as occurring 

* after installing a program which messed up PAM settings. 
* when the permissions on their X server were wrong. 
* dangling "IPC unix domain sockets" hanging around in /tmp. 
(I am not sure  which of the two directories "ls /tmp/.X*" 
lists is the one involved.)
* after installing XFS: http://oss.sgi.com/projects/xfs/installcavs.html

I got overwhelmed at that stage and stopped looking. Do any of
those ring a bell? 


More information about the Techtalk mailing list