[Techtalk] XF86 Upgrade Woes

Ellie ellie at mn.rr.com
Fri Aug 17 10:27:32 EST 2001

I am running Mandrake 8 with Nvidia drivers installed for my GeForce2 MX.
3D has been working, but oddly enough, only when I've been logged in as
root.  Recently I used the "handy" Mandrake Control Center to upgrade
different software packages, among which was XF86.  After I rebooted I could
not startx from my regular user account.  Root can still start the X server,
with 3D continuing to work.

Here is the error message I am getting when I attempt to log in as a regular

authentication failed - cannot start x server
perhaps you do not have console ownership? xinit: server error

I tried making a new user called test to find out if a new user would be
able to start x server.  When I tried to startx from this user account, I
received these errors:

Xauth: creating new authority file /home/test/.Xauthority
xinit: no such file or directory (errno2): unable to connect to x server
xinit: no such process (errno 3) server error

I found the files named ./Xauthority, but they seemed useless to the
situation.  Does anyone know what the remedy to this problem is?

Thanks very much in advance!  Ellie
> Techtalk mailing list
> Techtalk at linuxchix.simegen.com
> http://linuxchix.simegen.com/mailman/listinfo/techtalk

More information about the Techtalk mailing list