[techtalk] Desperate Plea for CDROM mounting help!!

arindamc at linuxfreemail.com arindamc at linuxfreemail.com
Tue Nov 21 05:23:22 EST 2000

At Sat, 18 Nov 2000 22:11:55 -0600 , "S. Stubbs" <2stubbs at bellsouth.net> wrote: 

>Hey, it has been a while now and I have not been able to mount my
>CDROM drive. I have mdk 7.2. I have one cdrom drive, it is recognized
>correctly in the hardware.
>It is IOMEGA Zip650 cd writer drive which is an internal IDE writer drive.
>PLEASE SOMEONE HELP, this is driving me nuts. I went to a Linux User
>Group install fest today, and they spent 6 hours trying to get it to work. They
> tried all kinds of stuff, even not using the supermount, and it still did not
>I am able toburn a CD just fine, I burned 2 CDs today, but I cannot mount the
>CDrom drive just to look at the contents of a CD. I still think in my mind that
>has something to do with permissions and links to CDrom.
>Here is my fstab right now, of course the LUG tried all KINDS of config here,
>but since none of it worked I finally have it as this:
>> /dev/hdb5  / ext2 defaults 11
>> /dev/hdb1  /boot ext 2 defaults 12
>> none /dev/pts devpts mode=0620 0 0
>> /mnt/cdrom /mnt/cdrom supermount user, fs=ISO9660, dev=/dev/cdrom 0 0
>> /mnt/floppy /mnt/floppy supermount user, fs=vfat,dev=/dev/fd0 0 0
>> /dev/hda1 /mnt/windows vfat user,exec,unmask=0 0 0
>> none /proc proc defaults 0 0
>> /dev/hda2 swap swap defaults 0
>I have also gone to the Mandrake website and followed the instructions there
>for getting a CDburner to work. I can provide more info if necessary. So what
>Could someone reply with a personal troubleshoot session on this??
>PLEASE, this is the ONLY PROBLEM I have now, I did get my Samba
>working like a champ, and can see both my other windows boxes.
>IF i don't get this fixed I will have to GIVE UP ON LINUX, since I will not be
>able to view a CDROM!!! I will not be able to update any rpms from the
> install CD!!! PLEASE this is a DESPERATE PLEA for help.

hi susan,

 i think u didnt get my previous mail. some problem with linuchix or
 my mail server.

 /dev/cdrom is a soft link to the actual device /dev/hdc(in my system)

u check the link by ls -l /dev/cdrom.

/dev/hdc is a block device with some standard major and minor no.

ls -l /dev/hdc gives

brw- .....         major-no minor-no. .....

this two numbrers should match with those specifid in ur system
specification.(devices.txt in my system).

u can create the device using mknod. man mknod will give u required

and make sure that u have read permission to /dev/hdc(or something 
else in ur system).

let me know what happens with error messages if possible.

arindam c.

Get your own FREE E-mail address at http://www.linuxfreemail.com
Linux FREE Mail is 100% FREE, 100% Linux, and 100% yours!

More information about the Techtalk mailing list