[techtalk] strange mail behavior

Samantha Atkins samantha at isis.aurinia.com
Mon Feb 21 02:05:49 EST 2000

I am experiencing something peculiar with sendmail.  First my set up is
that I have two other domains all sharing the same IP address.  I would
like mail to x at domain1 and x at domain2 to simply go to x at localhost.  I
found the sendmail.cw file as a logical place to express that my machine
has several domains on it.  So I added them in there, went out to a
remote shell account, telnet'ed into smtp and tried it out.  Sure
enough, the addresses at domain1 and domain2 appear to work fine.  

Everything seemed happy for some time.  Then about a week ago my machine
crashed one night due to a local power glitch.  When rebooted I started
getting 550 errors of relaying denied.  Very strange.  I tried reworking
my files.  At some point I got it into my head that I could use
something like /etc/mail/virtusertable to do what I was trying to do. 
So I tried that.  Seemed to more or less work.

But I noticed something strange.  Some of my mail from x at domain1 and so
on didn't seem to ever arrive at the mailing list it was sent to.  Nor
did I get a message it was rejected.  I also noticed that some of the
mail from various lists was simply never arriving.  It was as if
sendmail had put some incoming and outgoing stuff into some kind of
circular file.

Also, I noticed that some of the dates for sendmail files were the
original ones from Redhat 6 even on files I am pretty darn sure I
changed.  I began to wonder if someone wasn't attacking my machine and
playing with sendmail for some reason, perhaps to open it fully to
relaying, and attempting to cover their tracks. 

So today I tossed out the virtusertable changes and reinstalled all the
sendmail stuff keeping my sendmail.cw.  Again, testing from outside
seems to work just fine.

Anyone have any idea what the heck might be going on or something else I
might try?

Also, I am using Netscape 4.7 Communicator for email.  Does anyone know
if it has a habit of sometimes losing mail?  I tried using kmail but it
is pretty primitive (at least before KDE2.0) and has some strange
behavior of its own.

- samantha

techtalk at linuxchix.org   http://www.linuxchix.org

More information about the Techtalk mailing list