[Techtalk] Sound problem

Miriam English mim at miriam-english.org
Sat Dec 3 13:21:04 UTC 2016


Did you get any responses about your sound problem? Have you solved it? 
Sorry I didn't respond earlier. I'm not terribly knowledgeable about 
sound systems and put off replying because I figured somebody knew 
better than me.

If you run hardinfo and under Computer > Kernel Modules look for entries 
that begin with "snd_" you should find several entries that give clues 
to your audio system.

I've noticed sometimes VLC didn't correctly find my audio output and 
needed to be told in its settings.

If you have alsamixer I believe that sets the audio system output.

Maybe jack is taking over the sound and not letting other programs get a 
look in. Try shutting down jack to see.

What about low-level programs? Do you have sox installed? It has the 
"play" program that lets you play sounds from the commandline. It also 
gives some diagnostic messages too.


     - Miriam

David Sumbler wrote:
> I have an HP laptop which came with Ubuntu 14.04 installed, but some
> weeks ago I did a new install of Ubuntu Studio 16.04.  The reason I
> chose this is because one of my projects involves recording and editing
> MIDI, and I thought that Ubuntu Studio would perhaps make things
> easier.
> I can get sound from the speakers or earphones when I use QjackCtl and
> programs such as Qtractor, because I can choose the output device.  So
> I can get on with my MIDI project.
> But for programs which don't naturally interface with Jack I can get no
> sound at all.  When I use Chrome, VNC etc. I have no sound available.
>   And I do want to use this laptop as a general-use computer when I am
> away from home.
> I have asked on the ubuntu-studio-users list and received some advice
> from one person, but to no avail.  I have also asked on the Ubuntu
> forums, but I have had no replies.
> I'm wondering whether one of our technical experts on this list can
> tell me what I need to do to sort out the problem - I dare say it's
> just a matter of some basic settings.
> In QjackCtl I have input and output sources set to hw:Generic which is
> HD-Audio Generic (hw:1). Using this I can get sound via Jack through
> the computer speakers or headphones, but not from VLC etc. which don't
> have an option to direct sound through Jack, so far as I can see.
> The other main option is hw:HDMI which says HDA ATI HDMI (hw:0). The computer has an HDMI socket, but when I have tried connecting this to a TV I still get no sound. In any case, I don't generally want to use the HDMI output.
> Using alsamixer I have lots of controls for input and output volumes if I select Sound Card 1 (HD-Audio Generic), but if I select Sound Card - (default) or Sound Card 0 (HDA ATI HDMI) I just get a little square in the middle of the screen showing "00" and labelled "S/PDIF", whatever that means.
> In fact alsamixer is the only sound control I have (I think): when I
> click on the "All settings" icon, I see most of the expected items such
> as Display, Keyboard, Printers etc. etc., but there is no entry for
> Sound or anything similar. Equally I have no sound icon in the panel at
> the top of the screen.
> Incidentally, I normally have pulseaudio disabled, but I have also
> tried having pulseaudio running; I still get no sound from VLC etc.
> Can anyone suggest how I can get sound working generally (not just for
> specialized programs) on this computer?
> David
> _______________________________________________
> Techtalk mailing list
> Techtalk at linuxchix.org
> http://mailman.linuxchix.org/mailman/listinfo/techtalk

There are two wolves and they're always fighting.
One is darkness and despair. The other is light and hope.
Which wolf wins?
Whichever one you feed.
  -- Casey in Brad Bird's movie "Tomorrowland"

More information about the Techtalk mailing list