[Techtalk] disk labels and external drives

Miriam English mim at miriam-english.org
Tue Jun 29 23:21:07 UTC 2010

Hi LittleGirl,

Thanks for the suggestion, even though it didn't work. :(
I kinda expected it wouldn't because /media is just another place to 
mount stuff. Ubuntu, and I think Debian, have begun using this for USB 
devices, but mine (Puppy) doesn't, by default. Nevertheless I gave it a 
shot, just in case there was something weird I didn't know about.

Hang on... your reply has caused me to think about other, larger 
distributions. I have encountered weirdness in Puppy before due to the 
fact that a lot of effort has gone into cutting it down to the bare 
minimum. I just took a closer look at Puppy's "mount". By default it 
seems it uses "busybox". I've had trouble with this program before. It 
is a multi-purpose binary, containing many different commands. 
Unfortunately in order to cram so much into a tiny program it omits a 
lot of extra functionality. Busybox's mount doesn't recognise labels! 
Mystery solved. Puppy also includes the full version of mount (why 
doesn't it use that I wonder?). When I try mounting with "mount-FULL" I 
can mount external drives using labels.

Woo hoo!

Thanks Little Girl for jogging my thoughts.


Little Girl wrote:
> Hey there,
> Miriam English wrote:
>> I created the appropriate directory /mnt/wd1
>> then entered a line in fstab
>> LABEL=wd1  /mnt/wd1  ext3  defaults  0 0
>> but when I tried to mount it
>> mount /mnt/wd1
>> it returned the error:
>> mount: mounting LABEL=wd1 on /mnt/wd1 failed
>> Using blkid on the appropriate /dev address
>> blkid /dev/sdb1
>> returns:
>> /dev/sdb1: UUID="587c12bc-e5da-4a55-a40f-8a5d057e6020"
>> SEC_TYPE="ext2" TYPE="ext3" LABEL="wd1"
>> It's not mounted, but blkid can see it, so I expect mount should be
>> able to see the label too. I wonder what I'm doing wrong.
> I could be totally wrong, but since it's USB, it probably wants to be
> considered media, so try this:
> LABEL=  /media/wd1  ext3  defaults  0 0
> If it doesn't work, I'll go back to lurk mode. (:

If you don't have any failures then you're not trying hard enough.
  - Dr. Charles Elachi, director of NASA's Jet Propulsion Laboratory
Website: http://miriam-english.org
Blog: http://miriam_e.livejournal.com

More information about the Techtalk mailing list