[Techtalk] Navigating dependencies (Ubuntu/Easy Peasy)

Amanda Babcock Furrow alb at quandary.org
Sat Jul 25 17:27:10 UTC 2009

Hello all!  So I am happily fiddling with my netbook and its Easy Peasy 
(Ubuntu-based) distribution - finally a "real" LinuxChick, as before
I only had an effectively headless FreeBSD server and a Windows laptop
(and some random non-running Sparc hardware!) - and now I need to 
compile a patched version of bluez-gnome and am running up against
issues that I don't want to just go blindly wading into.  Dependency

Easy Peasy 1.0 is an Intrepid Ibex-based distribution which comes with
bluez-gnome 1.8-0ubuntu1 installed, which has a design issue that prevents
me from pairing my Bluetooth speaker.  I've downloaded the tarball for
bluez-gnome-1.8 from launchpad, and made the necessary changes.  But
when I run ./configure to create the makefile, it says:

configure: error: dbus-glib >= 0.73 is required

which appears to happen because 'pkg-config  --exists --print-errors 
"dbus-glib-1 >= 0.73"' fails.  But I do have a package installed as
libdbus-glib-1-2, with version 0.76-1, so unleess that is a
different package, the test shouldn't fail.  

pkg-config seems to be looking for a file dbus-glib-1.pc.  But there is 
no .pc file for dbus-glib-1 or libdbus-glib-1-2; searching

abf at niterinep:~$ ls -ald /usr/*/pkgconfig/*dbus-glib*.pc

gives only

-rw-r--r-- 1 root root 290 2007-10-24 07:33 /usr/lib/pkgconfig/ndesk-dbus-glib-1.0.pc

which seems to be a different package entirely.

So, my dilemma: do I: 1) edit ./configure to make it ignore the test;
2) deinstall and reinstall dbus-glib to see of the .pc file appears, at
the risk of fatally confusing my computer; 3) something else?

(I guess that's technically a trilemma :)


More information about the Techtalk mailing list