[Techtalk] New OpenOffice bails out at 'Welcome to OpenOffice.org" screen

B Seeger seeger at prosensing.com
Mon Jun 30 13:05:41 UTC 2008

An issue I've had repeatedly with openoffice  (on debian 2.6.18) is that
it tries to use Open GL and fails to start. I get the welcome screen,
then it's gone. I get a forking error on the command line (if I run it
from a terminal). 

After many weeks of trying to fix it on and off, I finally found the
tweak I needed.

In /usr/bin/soffice I needed to uncomment the following line: 

# Uncomment the below line if you suspect that OpenGL is not
# working on your system.
export SAL_NOOPENGL=true;

Things worked fine after that. Sometimes after and apt-get upgrade I
have to re-edit this lovely file.  (if someone knows why this worked,
let me know -- I know next to nothing about openGL.)

I don't know if this is the problem you're having, but just thought I'd
mention this in case it is. 

If you run open office from a terminal, what error do you see? 

Also, you can do this: 
prompt$ strace -f openoffice 

which will give you more in-depth details about failures to help trouble
shoot it. 


On Mon, 2008-06-30 at 01:53 +0200, Wim De Smet wrote:
> On Sun, Jun 29, 2008 at 10:42 PM, Anne Wainwright
> <anotheranne at fables.co.za> wrote:
> > I'm all out of ideas. None of the OOo utilities run, all behave as
> > described. Maybe I must try removing and reinstalling again, but not
> > tonight. What have I missed?
> If openoffice crashes it probably logs something to .xsession-errors,
> try it again and have a look if you can't find anything more in there.
> Also, are there any settings of openoffice you want to keep? If not,
> you might just solve it by remove the .openoffice directories in your
> home, or moving them out of the way if you're not sure.
> greets,
> Wim
> _______________________________________________
> Techtalk mailing list
> Techtalk at linuxchix.org
> http://mailman.linuxchix.org/mailman/listinfo/techtalk

More information about the Techtalk mailing list