[Techtalk] Gentoo Kernel Upgrade - unable to mount root partition

Kat binaryjane at gmail.com
Mon Oct 29 07:43:34 UTC 2007

Hey AstroGirl!

One of the reasons I procrastinate when it comes to upgrading, is that
I invariably find myself googling error messages in the wake of it.
Sometimes it takes days, sometimes it takes hours, and sometimes it is
fixed in minutes.

The thing is, I never know which it is going to be, and I feel
completely amputated without my computer. Not just any computer (there
are at least four other computers I can use at any one time, but MY
computer is just the way I want it. Ahem. Mostly).

Anyway, I'll try this in the morning!


On 10/28/07, AstroGirl <astrogirl at spin.net.au> wrote:
> On Mon, 29 Oct 2007 10:42:09 am Kat wrote:
> > I've had a few crazy months where keeping my box up to date has been
> > really low on the list of priorities. Today I finally got around to
> > upgrading my kernel from 2.6.20 to 2.6.22.
> >
> > When I try to boot into the new kernel, I get the error message:
> > Root-NFS: No NFS server available, giving up.
> > VFS: unable to mount root fs via NFS, trying floppy
> >
> > My root partition is on /dev/sda5
> >
> > By changing root=/dev/sda5 to root=0305 in the grub.conf file, I was
> > able to get past that point in the boot process, but then I got
> > complaints that fstab doesn't define /dev/hda5... which is because
> > I've got that down as /dev/sda5.
> >
> > I don't dare edit the fstab to reflect the hda thing, since I'm pretty
> > sure I won't be able to boot into this (2.6.20) kernel if I do.
> >
> > Any idea what sort of changes I should try in the menuconfig?
> >
> > Any other things I can look at to figure out what exactly is causing this?
> Hi Kat,
> I'm by no means an expert in this - but I had the exact same error when
> installing Gentoo for the first time about 2 weeks ago. What I did to fix it
> involved using the liveCD and finding out which modules it loaded, then
> finding out what process "calls" the module, and then searching in Menuconfig
> for the process - the long and the short of it was that it was my HDD not
> being detected properly.
> I'm using kernel 2.6.22 as well. It looks like you have a Sata drive? (Me too)
> Under "Device Drivers", there is a "Serial ATA (prod) and Parallel ATA
> (experimental drivers)" section you have to say yes to.. and then hit enter
> to get inside that menu (I didn't realise I could do that and it took me 2
> days to find out), and choose the correct driver in there and make sure it's
> not a <M>odule, but a *. Mine was an Intel PIIX3 support one - worked like a
> charm, no more kernel panics. :)
> I hope that was of some help.
> AstroGirl
> _______________________________________________
> Techtalk mailing list
> Techtalk at linuxchix.org
> http://mailman.linuxchix.org/mailman/listinfo/techtalk

More information about the Techtalk mailing list