[Techtalk] upgrading debian

Maria McKinley maria at shadlen.org
Thu Aug 23 22:50:26 UTC 2007

Akkana Peck wrote:
>>On 2007-08-23 02:39, Maria McKinley wrote:
>>>I upgraded my kernel from 2.4 to 2.6. If I boot into 2.6, networking 
>>>does not work. I have tried all sorts of things to get it to work 
>>>(mostly making various changes to /etc/network/interfaces), but can't do 
> Gina Lanik writes:
>>Does your machine have multiple network interfaces? If yes it might be
>>an issue with udev and persistent-net.rules?
> I hit that in Etch too, but I wasn't able to find a way to fix
> persistent-net.rules to work the way I wanted. I ended up
> blacklisting the modules I didn't want, instead (which in Debian
> isn't easy and requires a hack).  I wrote up the details:
> http://shallowsky.com/blog/linux/etch-firewire-net.html
> Ah, but I didn't find the page Gina mentions, which links to
> http://www.debian.org/releases/etch/i386/release-notes/footnotes.en.html#f11
> which says to just delete
> /etc/udev/rules.d/z45_persistent-net-generator.rules to disable
> persistent renaming altogether. That's probably a good approach,
> though it's too bad you can't keep persistent renaming for some
> devices while disabling it for others.
> But if Maria has already been fiddling with /etc/network/interfaces
> she has probably already compared the interface name there with what
> shows up in ifconfig -a (if not, Maria, check that first).
> Maria, what's it doing or not doing? Does the interface show up in
> ifconfig -a? What happens if you /etc/init.d/networking restart
> from the command line? Any error messages there, or in dmesg or
> /var/log/messages?
> 	...Akkana

Thanks for the advice everyone. The machine does have multiple network 
interfaces. I looked at the /etc/udev/rules.d/z25_persistent-net.rules 
file, and saw that the interface for the card of interest was changing 
from eth0 to eth1. Now, I had definitely tried using eth1 instead of 
eth0 in interfaces before, but it has happenned to me before that when 
you start making lots of changes to interfaces it is almost like it gets 
confused and refuses to let anything work. At any rate, when I tried 
this as the first change, and rebooted the machine, suddenly it had a 
network with the 2.6 kernel. Sometimes computers just drive me mad.

Wim, sounds good to try aptitude. I knew of its existence, but had 
always used apt-get and never bothered to find out how they were 
different. Sounds like an improvement for sure. So, I will run fsck on 
the disk, but at this point I think I should be able to get the machine 
running properly without starting from scratch.


More information about the Techtalk mailing list