[Techtalk] Problems Compiling XFree86

Maluvia terakuma at imbris.net
Sun Sep 11 09:20:46 EST 2005

I hate to bother you guys with such a basic question, but pride goeth before a fall - and I'm going down. ;)

I'm trying to compile XFree86 v.4.5 for an AMD64 system, (actually, I just want the TinyX server off it), and can't get to square one.
It keeps exiting from the compile almost immediately saying:

make[2] Makefile.proto: No such file or directory.
make[2] *** No rule to make target 'Makefile.proto'. STOP
make[1] [depend.bootstrap] Error 2
make: *** [World] Error 2

My environment is as follows:
CFLAGS="-march=k8 -O2 -pipe"
CXXFLAGS="-march=k8 -O2 -pipe"

(I tried the build with these both set and unset - didn't seem to make any difference.)

I've created a host.def file with:

#define TinyXServer  YES
#define DefaultGcc2i386Opt -march=k8 -O2 -pipe

I don't see how the problem could be with the host.def file though, as I tried a dry-run compile using just the default xf86site.def, and got the same results.
There is something very basic going wrong here, but I am not experienced enough to figure it out.

I suspect it has something to do with one or more of the configuration files in xc/connfig/cf such as a *.cf, *.tmpl, or *.rules.
(There is no x86-64 or AMD64.cf)
Possibly a path issue or something to do with includes.

If anyone can point me in the right direction towards solving this I would be immensely grateful.


More information about the Techtalk mailing list