[Techtalk] gtk versions question

Patricia Fraser trish at thefrasers.org
Sun Jul 17 12:01:11 EST 2005

Hi all,

I'm having an interesting problem getting Audacity to run on my system. 
I'm using Mandriva 2005LE, a clean install; previously I had run cooker 
and then updated it, and had no problems there.

The error I get (regardless of version) on running Audacity is this:

(audacity:7706): Gtk-CRITICAL **: gtk_accel_label_new: assertion 
`string != NULL' failed

(audacity:7706): Gtk-CRITICAL **: gtk_misc_set_alignment: assertion 
`GTK_IS_MISC (misc)' failed

(audacity:7706): Gtk-CRITICAL **: gtk_container_add: assertion 
`GTK_IS_WIDGET (widget)' failed

(audacity:7706): Gtk-CRITICAL **: gtk_accel_label_set_accel_widget: 
assertion `GTK_IS_ACCEL_LABEL (accel_label)' failed
Segmentation fault (core dumped)

I've tried various versions of wxgtk and wxgtk-devel, and tried various 
versions of Audacity with all of them, but I'm beginning to think that 
it's actually a mismatch between the wxgtk libraries and gtk itself. 
Has anyone got any ideas how I would go about finding the right match?

I've downloaded the source rpm and rebuilt it - same problem. I've 
downloaded both the stable and cvs sources and been unable to compile 
them, which is where I got the idea about the mismatch from - but I 
don't understand the compile errors enough to track down the fault.

Hope someone has some ideas; even a list of the gtk versions from a 
working system would be helpful!


Trish Fraser, Sunbury, Australia
zo jul 17 11:55:41 EST 2005
GNU/Linux 1997-2004 #283226 counter.li.org
andromeda up 20 hour(s), 59 min, 59 sec
kernel 2.6.11-6mdk

More information about the Techtalk mailing list