[Techtalk] Trying to patch the kernel...

Akkana Peck akkana at shallowsky.com
Sat May 31 12:48:36 EST 2003

Sara writes:
> I've done already "patch ...." and I think that's OK. But I'm trying now to 
> configure the kernel, so I've tried   "make menuconfig" and "make xconfig" in 
> my /usr/src/linux directory, but that gives me the error: "make: *** No rule 
> to make target `config'.  Stop." Same with xconfig. 
[ ... ]
> The contents of my linux directory are: Documentation  include 
> (in case that info could be useful)

Just those two?  Somehow you've only got a small part of the kernel
source.  You should have a whole bunch of directories there, including
arch, drivers, fs, init, ipc, kernel, lib, mm, net, scripts (and some
other files).  I'm surprised patch worked without errors, since the
ACPI patch changes files under directories you don't have.

What kernel source did you start with before you applied the patch? 
Was it a tarball named something like linux-2.4.20.tar.bz2 ? 
It might be best if you made a new directory (it doesn't have to be in
/usr/src/linux -- just extract it somewhere convenient like your home
directory), extracted the kernel source there, then apply the acpi
patch, then make xconfig or menuconfig.  Whatever you've got now
in /usr/src/linux, it sounds like it may be incomplete and you
might be better off starting over.


More information about the Techtalk mailing list