[Techtalk] Cisco routers anyone?

nicole colby at wsu.edu
Thu May 8 18:35:32 EST 2003

You do need to be in interface mode to set the IP. You might try 'show
interfaces' (in enable mode) to see what interfaces you have to choose
from. Make sure you know which is LAN and which is WAN.

Also they are numbered, so you will have to use "0" for the first
interface of that name. So, interface vlan 0 might have worked.

The biggest thing with cisco interfaces is to remember the question mark.
If you're not sure, just hit the question mark and it will tell you what
you "should" be looking to put in that space. Example:

c1720-ios(config)#interface ?
  Async              Async interface
  BVI                Bridge-Group Virtual Interface
  CTunnel            CTunnel interface
  Dialer             Dialer interface
  Ethernet           IEEE 802.3
  FastEthernet       FastEthernet IEEE 802.3
  Group-Async        Async Group interface
  Lex                Lex interface
  Loopback           Loopback interface
  Multilink          Multilink-group interface
  Null               Null interface
  Tunnel             Tunnel interface
  Vif                PGM Multicast Host interface
  Virtual-Template   Virtual Template interface
  Virtual-TokenRing  Virtual TokenRing
  range              interface range command

c1720-ios(config)#interface fastethernet?

c1720-ios(config)#interface fastethernet ?
  <0-0>  FastEthernet interface number

c1720-ios(config)#interface fastethernet 0

At that point I can enter the IP for that interface (the command you have
should work).

Things like 'ip route' are globals, while 'ip address' is a per-interface


At 17:43 on May 8, Mary Wood shook the earth with:

> Before I can dive into my first Linux swimming pool,
> we must get the router configured. And there's already
> a snag I hope someone has an easy answer for.
> It's a used Cisco 1700 router. I need to assign it a
> new IP address, as it's currently showing the addy for
> its old home. I'm interfacing through a Window$
> machine, using SecureCRT.
> I'm in global config mode, trying the entry:
> router(config)#ip address 12.345.678.9
> 12.345... being the new ip we want and 255... being
> the subnet.
> It's telling me "%invalid input detected at..." and
> indicates the problem is the space between "address
> 12.345..." I've tried no space, dash, semi-colon,
> though I'm certain that a space is correct.
> I'm also suspecting I should be in interface mode, but
> can't for the life of me get there. I'm trying:
> router(config)#interface vlan
> I get the error "%incomplete command" I pulled up a
> list out of the help file of the various interfaces
> one can use and I get the same "%incomplete command"
> with all of them. Incedentally, I don't know which
> interface I should be in, just that I'd like to get
> into interface mode to try changing the ip address
> from there.
> Sigh. Feel like I've absorbed everything else under
> the sun today about Cisco routers *except* how to
> change the ip address. >_<
> Anyone have any suggestions?
> Thanks in advance...

More information about the Techtalk mailing list