Update Re: [Techtalk] RH9 upgrade problem

Conni ccovingt at one-eyed-alien.net
Tue Jun 24 12:23:06 EST 2003

Now it's b0rked even worse, and I don't have the knowledge base to fix it.

I eventually gave up with the CD install and did it from the hard drive.
Now, I seem to have an even bigger issue:  kernel panic.

Here's the last 5 lines before it freaks out and gives up:
mount error 22 mounting ext3
pivotroot: pivot_root (/sysroot, /sysroot/initrd) failed: 2
umount /initrd/proc failed: 2
freeing unused kernel memory: 132K freed
kernel panic: no init found.  try passing init= option to kernel.

It uses grub, not lilo, so I can't just type "linux single" and play
around that way.  In fact, I haven't the first clue how to get it to do
anything other than boot.

The config (pressing 'e' in the loader screen) shows this:
root (hd0,0)
kernel /vmlinuz-2.4.20-8 ro root=LABEL=/
initrd /initrd-2.4.20-8.img

The one for a different (though not the one I was using until earlier
today; this is a failed attempt at self-compiling a kernel, and booting
into it isn't very helpful; it doesn't even find eth0) kernel reads thus:
root (hd0,0)
kernel /vmlinuz-2.4.17 ro root=/dev/hda2 pci=biosirq
initrd /initrd-2.4.17.img

I tried editing it so the 'kernel' line looked the same, and that didn't
help.  I tried 'linux single,' but grub apparently doesn't like that.  I
added 'init=3' to the kernel line, and that didn't help, either.

Does anyone else have these sorts of problems, or do the kernel gods just
hate me?


Would now be an appropriate time to say that you disturb me?  


More information about the Techtalk mailing list