[Techtalk] RH9 upgrade problem

Akkana Peck akkana at shallowsky.com
Mon Jun 23 07:25:56 EST 2003

Conni writes:
> I finally decided to upgrade from RH7.2 to 9, so I downloaded the ISOs
> from ibiblio and burned them to CD (on the husband's iMac.)  This is where
> the problem starts.

Redhat 7.x and 8 understood Sony PCMCIA CDROM drives, or at least mine
-- it was one of the few installers that did.  Unfortunately, they
seem to have removed that support in RH9, which didn't work on my
SR17 either, so now Redhat 9 is just as hard to install on a Vaio
as Debian or anything else.

With other installers (e.g. Debian and SuSE), on the SR17 and SR33,
the magic words to stop the installer kernel from losing the CDROM as
soon as it loads PCMCIA are these, uttered when you first boot from
the CD into the installer:

linux ide2=0x180,0x386

I hope your CD appears in the same place ours does, so this will work
for you ...  Note that I haven't actually tried this in RH9 yet.  When
I tried RH9 I was in a hurry, and when the installer didn't work I
didn't have the incantation handy so I installed RH8 instead (which
I'm using to type this).

Conni writes:
> (There is apparently a hardware-related toggle for LCD/VGA, as well as a
> sort of mousewheel, neither of which I've gotten functional, despite Dave
> and Akkana's amazing aid.  I also can't get suspend to work, because the
> hardware doesn't support apm, only acpi.  Then there's the internal
> wireless ethernet card.)

Software suspend is making good progress and approaching a release.
In a few weeks or a month, you may be able to suspend-to-disk (which
is pretty fast, though admittedly not as fast as APM bios suspend)
using a 2.4.20 or 2.4.21 kernel.  ACPI suspend is unfortunately a
long way off (it looks like it'll never be backported into 2.4).
I feel lucky that I got an earlier model that still uses APM.

Oh, but Conni, if you haven't tried the 2.4.21 kernel yet, it might
be worth trying that for the sonypi driver.  I think I saw some notes
about sonypi patches to make it work better with ACPI.  Maybe it'll
fix the problem with your jog dial ...

> I wonder which button I push at boot to get the BIOS options.  I don't
> think it's f1; I've tried that.  It flashes past too quickly to see what

I think it's F3, or maybe F7.  It's too fast to read on mine too,
but pressing several F-keys in sequence usually gets it for me.

> What makes this more annoying is the fact that I got RH7.2 onto this
> computer (with minimal issues) using the same exact stupid disappearing
> CD-ROM.  Except it didn't disappear then.

Right.  I wish I know why they removed perfectly good Sony CD support!
Try the ide= incantation and see if it helps.
If not, there's always Redhat 8 ...


More information about the Techtalk mailing list