[Techtalk] cups problem

David Sumbler david at aeolia.co.uk
Thu Aug 21 10:02:06 EST 2003

I recently bought an HP PSC-2210 (printer, scanner, copier).  On my
RedHat 8.0 machine I have built hpoj, which seems to work OK, and run
basic tests, which are all OK.  But I can't get the HP machine set up
to print (using hpijs).

I downloaded the appropriate ppd file (HP-PSC_2210-hpijs.ppd) from
linuxprinting.org, put it in the /usr/share/cups/model/foomatic/HP/
directory with the ppd files for other HP PSC machines, set the
appropriate permissions on it, and did 'killall -HUP cupsd' to refresh
the cups database.

But when I try to install the printer using the cups web admin tool,
the new printer does not show up with all the others.  Yet if I do
'lpadmin -m' it is listed OK.

I've tried renaming the file HP-PSC_2210-hpijs-cups.ppd, running gzip
on it, (to make it like the other files in the folder), moving it up a
directory or two - none of it makes any difference.  I've also
rebooted several times.

I tried to install the printer using lpadmin from the command line.
No error was shown, but when I checked the printer in the cups admin
it was not set up correctly, and a test page produced garbage.

So how do I get the new printer's ppd to show up?  (A message posted
on one of the cups mailing lists unfortunately produced no response,
so I thought I'd ask some of you experts!)



More information about the Techtalk mailing list