[Techtalk] Diagnosing a hardware problem (long)

Vera Childs vera at dc-vc.net
Thu Nov 14 16:45:29 EST 2002

Hi, I'm new to the list (joined late last week, I think). I've been using
Linux as a "2nd OS" since about '97, always using Redhat. Recently, I
decided to try out Mandrake 9.0 at home, and fell in love with it. My
Windoze at home had gotten to where it wouldn't install a print driver, and
the printing system would crash on boot. Linux has no problem with any of
my home hardware. When I get time, I'll be making my Windoze partition
significantly smaller. :)

Anyway, now I'd like to use Mandrake 9.0 at work as well. I've been dual
boot with Win2k and Redhat 7.3, and I decided to just replace the Redhat. I
brought in my CDs that I burned at home.

Problem #1: The install kernel won't boot. It freezes after some stuff
about assuming 33MHz system bus speed for PIO modes, then lists ide0 and
ide1 stuff. Then it just hangs (keyboard hangs, etc.). So I got the
alternative install kernel, which I think uses 2.2.19. Now I *know* a 2.4
kernel will run on this machine (Redhat 7.3), but maybe the latest one
isn't happy. I dunno. The alternative disk boots.

Problem #2: The CDs had errors installing a bunch of rpms. I went back into
Windows and tried to copy the stuff over to the harddrive. Didn't work. My
CDROM got into this recursive state of spinning up and then back down, and
I had to kill the process from the task manager. My officemate copied the
CDs over to his harddrive, then put them up on the network, then I copied
them to my harddrive. Ok, I'm doing a harddrive install now (what I did at
home anyway).

Problem #3: Using the alternative disk, I went through the install. When it
got to the end, as it said it was going to restart the machine now, it hung
again, but this time I still had use of the keyboard. I changed consoles
and found that it had errors writing cache when accessing hdb (the drive I
was installing onto). That sounds bad. :) Another thing that happened on
last night's install attempt, which didn't happen the first time, was that
as it was writing the kernel rpm, it had a problem. It's copying from one
partition to another on the same drive (the CD contents are on a FAT32
partition). I told it to go back and try again, and things went fine until
the restart hang thing. Now when I reboot, I get the lilo screen and can
choose Windoze to boot, but Linux brings up the Mandrake screen where it
puts the boot text in the square area, except no text ever shows up. The
system hangs (hard freeze again). The boot floppy that I created says the
kernel isn't there, so it can't boot either. :/

Problem #4: Incidentally, I tried installing Redhat 8.0, and it freezes at
the same point most of the time on install boot, but I did get it to get
past that twice (without changing anything!), and it installed and booted
fine. I just don't like it. I'd rather use Mandrake 9.0. *sigh* But during
the Redhat 8.0 installation, as I was partitioning the drive (which
Mandrake had somehow gotten the partition tables all funky, so Windoze
thought it was a 24gig drive instead of 12gig), it didn't want to create
the partition toward the end. I've now got about 40MB unallocated there
because it was sometimes dying when creating a partition that went near

Ok, so I've downloaded the IBM Disk Fitness Test program and checked out my
harddrive (a Western Digital - couldn't get their software to work, since
the latest version didn't support my drive, and the older version requires
Win9x/ME to write the floppy - grrr). Everything checked out fine. I've
also run the memtest86 that comes on the Mandrake CD. After about an hour
and 20 minutes of testing, it still hadn't found any errors. I'm going to
run it again overnight.

So given the symptoms I'm having, does anyone have any clue where I should
go from here? Or should I give up on trying to install Mandrake 9.0? The
installation was absolutely painless at home, and I swear my work machine
is just falling apart, bit by bit. I already lost a harddrive earlier this
year, plus a mouse. And my monitor does some funky power things on
occasion, and it also has a high pitched squeal sometimes (my officemate
loves that - he thought his ears were ringing!).

Here's the basic specs:
This is a Micron Millenia desktop
750MHz Intel processor
8GB Seagate harddrive (Windoze is on this one)
12GB Western Digital harddrive (partitioned by Redhat's installation
NVidia Vanta video card
3COM Etherlink XL 10/100 PCI NIC
Ensoniq CT5880 soundcard
Logitech MouseMan Dual Optical (normally USB, but put into PS2 for the
installation, since Mandrake didn't like the USB)
USB Handspring Visor cradle
CDROM drive... I don't know the brand offhand

Any ideas would be welcomed. :)


More information about the Techtalk mailing list