VGA out, avi weirdness (was Re: [Techtalk] sonypid/spicctrl)

Conni ccovingt at
Sun Aug 18 15:46:52 EST 2002

On Aug 18, caitlynmaire at conjectured:

> You really need to upgrade that kernel.  There are known (and nasty)
> vulnerabilities in the kernel that shipped with RH 7.2.  Grab an updated
> rpm at

Do I need all the rpms (including kernel-boot, kernel-source, etc?)  A
while back, someone said you don't want to rpm -Uvh a kernel.  I'll dig
back and see if I can find how he said to do it.

> > I've also had no success getting the jogdial thing working right;
> > maybe if I get this sonypi installed right, I'll be able to fix that.
> It can work right.  This page was written for Debian, but it does
> mention that if you have sonypi installed the jogdial will work.

It hasn't yet, actually.  The VGA out does work, but it doesn't completely
switch, and I don't have enough video memory to do both (as evidenced by
some bizarre aviplay behavior where it worked fine before.)  The Fn/F7
combination doesn't really *do* anything, nor does Fn/F4 increase the
volume, nor Fn/F3 mute.  And the jogdial still doesn't work.  When I put
the line 'sonypid &' in .Xclients and startx, X starts, then fails, with
this as the last few lines: 

(**) Mouse0: Protocol: "PS/2"
(**) Mouse0: Core Pointer
(==) Mouse0: Buttons: 3
(**) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(II) Keyboard "Keyboard0" handled by legacy driver
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
waiting for X server to shut down (II) I810(0): [drm] removed 1 reserved
context for kernel
(II) I810(0): [drm] unmapping 4096 bytes of SAREA 0xd09ab000 at 0x40017000

I don't know why it just quits.  It *should* be right.  My
/usr/lib/X11/XF86Config looks right:  

Section "Pointer"
    Protocol    "GlidePointPS/2"
    Device      "/dev/psaux"

# Wheel support (no emulate 3 buttons)

ZAxisMapping 4 5

... Hmm, should the 'Emulate 3 buttons' section be commented out or left 
in?  Am I editing the right config file?  (Someone said once that I should
edit an XFree4 config file, but I can't seem to find it.)

But if I take away the .Xclients, x starts just fine.  *very confused*

> > I have, however, gotten divx/aviplay mostly working, thanks to a
> > friend who made me nice rpms.  The 'mostly' part is this blue line on
> > the side of the video.  Don't know where it's coming from.  Very odd.
> There are new divx rpms at  I know the one for 7.3
> does not have that problem on a Toshiba or IBM.  No Vaio here.  Again,
> sorry.

I got the rpms from a friend in CT, who forced them to work on his laptop
(not a vaio, granted, but he got it working.)  So now it works, except
that some files it plays the audio very poorly (at double speed, to make
up for the hiccups where it plays nothing.)

This is normally where I just throw my hands up and give up, and wait for
a newer kernel or what have you.  Unfortunately, I *really* need to get
the VGA out and divx working by 9/10, because I've said I'd let the anime
club show digisubs from my laptop.  (Or I could just give up and say I
can't get it working, so someone else needs to be laptop monkey.  Which
I'm leaning toward, honestly.)

growing increasingly frustrated.

I'm having some difficulty with the idea that an AI needs nookie.
			-Michael, User Friendly 6/01/99

More information about the Techtalk mailing list