[Techtalk] RH 7.2/KDE

Akkana akkana at shallowsky.com
Mon Oct 29 10:53:55 EST 2001

Raven Brooke writes:
> I have recently installed Red Hat 7.2 on a few machines, and am having a 
> problem with KDE on just _one_ of them. I have tried swapping between 
> three different videocards, and reinstalled with one of them to no avail. 
> The problem is as follows: when starting x, the startup icons on the 
> splashscreen happily flash until the "window manager" one is reached, then 
> the machine locks up hard. I mean ctr-alt-backspace wont kill x and I have 
> to actually powercycle the machine. I have no trouble launching gnome, 
> only KDE. Specs for this machine are:

Interesting.  I had the same problem on my Vaio SR17 laptop, running
Redhat 7.1 (and the kde packages which came with that, 2.1-various),
but only with a 2.4.7 kernel.  Initially, using Redhat's 2.4.2 kernel,
kde worked fine and I was using it, but after I built 2.4.7, I got
lockups every time I tried to start kde; I had to pull the battery out
to reset the machine, and on reboot fsck always found numerous
filesystem problems, so I wasn't motivated to spend a lot of time fixing
it for fear of horking my filesystem.  There are other things I didn't
like about kde2 (I loved kde 1, but newer versions just seem to be
getting bigger and slower and more intrusive) so I decided it was time
to switch to gnome/sawfish.

Now I'm running a 2.4.9 kernel, and I *think* I tried kde2 once and
it actually did start up under 2.4.9, but sawfish starts up so much
faster I've stuck with it and don't miss kde.

I never figured out what the actual problem was, so this isn't much help
unless it helps to know you aren't the only one and it's not just RH72.


More information about the Techtalk mailing list