[Techtalk] Filesystem corruption?

Brian Sweeney bsweeney at physics.ucsb.edu
Mon Nov 19 18:50:22 EST 2001

Hey all,

Having some weird filesystem corruption with a linux 2.2.5-22 ext2 box. 
  Here's the deal:

User's started complaining about files getting corrupted.  Log shows 
errors like the following:

kernel: EXT2-fs warning (device sd(8,33)): ext2_free_inode: bit already 
cleared for inode 372903
kernel: find_dentry_by_ino: getting root dentry for 08:21 failed
kernel: lookup_by_inode: ino 372903 not found in /

and similar errors.  I tried:

1) Swapping out memory
2) Swapping out hard drive
3) Swapping out SCSI controller
4) Swapping out SCSI cable
5) Swapping out NIC card (just for fun ;-))

Still get the error.  I'm about to recompile the kernel, but I don't 
think that's gonna do it.

Online I found issues relating to old 2.0 kernels with ext2fs 
corruption, and some other people swearing it had to be memory or hard 
drive, but that doesn't seem to have helped.

Any suggestions?


More information about the Techtalk mailing list