[Techtalk] Aiee, Kernel Panic! with scsi device

stephanie1200 at netscape.net stephanie1200 at netscape.net
Mon Nov 5 18:40:09 EST 2001

No, that's not me being cute, that's the kernelly wernelly being cute.

I have an athelon box from Penguin with a Symbios scsi host adapter (NCR53c7,8xx) with and NCR scsi bios (NCR SDMS V3.0 PCI SCSI bios PCI Rev 2.0) which, at one time, worked splendidly with my Yamaha external scsi cdrw (CRW8424).

But then I had to go and reinstall.

It seems that ever since I tried to install a little Linksys eth card from a  "network in a box" kit, my puter has Turrets.  First, the beep when the machine is powered on sounds like a dying bird (2 pitches instead of one) which I find very odd.  Next, my modem is seen but not functional in both win2000 and Red Hat 6.2...wait...maybe 7.1...well, 2.4.2 and 2.4.13 kernels in any case.  I am willing to attribute this to the modem frying b/c of dust during the weeks when the cover was off.  Whatever, I got a faithful ol' sportster external on there, no biggie.

the problem is this:  In win2000, the scsi card is seen and reports no problems, the scsi bios is the exact same one which previously worked in Red Hat, and the scsi card bios is the one that comes with the win install CD, and Symbios says that is the right one to use.  However, when I plug in my drive, it is never seen.  Already checked termination, scsi id, power strip turned on, blah blah.  No good.  desperately seeking new scsi bios, maybe that's it.

And yet, Linux acts much much wierder.  It usually boots and works fine, both kernels,  and I do believe the scsi card is seen in a hardware config, /proc, etc.  I haven't looked at that recently so i'm a little fuzzy.  When the cdrw is plugged in, it boots.  When it is *powered on* it doesn't boot.  It gets to a point of (I think) loading a scsi driver, doing something with scsi anyway, and the kernel panics like this:

"Unable to handle kernel paging request @ virtual address 0150ad0a
Printing eip: c01e2965
Aiee, Killing Interrupt handler!
In interrupt handler - not syncing"
and chokes and won't boot.  Again, both kernels do this, and I specifically recompiled yesterday with support for my specific card (NCR53c{7,8xx}).
What the hell did I do to this thing? Do I just have screwed up interrupts?  How do I fix it?  I swear i didn't move any jumpers. This problem has persisted through probably close to 10 OS installs between Win and Lin.  I am stumped, and a google search on my error produces exactly 2 completely useless hits.  I'm about to call up Linus himself.

Help, please. =(

Your favorite stores, helpful shopping tools and great gift ideas. Experience the convenience of buying online with Shop at Netscape! http://shopnow.netscape.com/

Get your own FREE, personal Netscape Mail account today at http://webmail.netscape.com/

More information about the Techtalk mailing list