[Techtalk] openssh/glibc installation problems on RH6.2

Nicole Zimmerman colby at wsu.edu
Fri Nov 2 15:49:10 EST 2001

Is there any way you can find/download an SRPM of OpenSSH? I suspect that
if you rebuild the package from the SRPM you will have more luck. That
said, I don't have experience rebuilding SRPMs for this sort of thing, but
it is certainly easier than re-installing or upgrading your entire box :o)

I have several debian stable boxes that use glibc2.1 that I was able to
install openSSH 2.9p2 on by rebuilding the packages against my own library
versions. I have done this a bunch of times with other packages too
(postgres 7.1 and mozilla come to mind). So the stuff *can* work with
glibc2.1, it's just a matter of how!


> I was trying to install the openssh and openssh-server  rpms on a
> RH6.2 machine which currently has glibc-2.1.3-15,
> and got the following dependency errors :
> [root at nml i386]# rpm -ivh openssh*
> error: failed dependencies:
>          initscripts >= 5.20 is needed by openssh-2.9p2-8.7
>          libcrypto.so.1   is needed by openssh-2.9p2-8.7
>          libc.so.6(GLIBC_2.2)   is needed by openssh-2.9p2-8.7
>          libcrypto.so.1   is needed by openssh-server-2.9p2-8.7
>          libc.so.6(GLIBC_2.2)   is needed by openssh-server-2.9p2-8.7
>  From what I can tell, it requires GLIBC 2.2 to work.

More information about the Techtalk mailing list