[Techtalk] openssh/glibc installation problems on RH6.2

wildgrass wildgrass at postone.com
Fri Nov 2 15:16:48 EST 2001

I was trying to install the openssh and openssh-server  rpms on a
RH6.2 machine which currently has glibc-2.1.3-15,
and got the following dependency errors :

[root at nml i386]# rpm -ivh openssh*
error: failed dependencies:
         initscripts >= 5.20 is needed by openssh-2.9p2-8.7
         libcrypto.so.1   is needed by openssh-2.9p2-8.7
         libc.so.6(GLIBC_2.2)   is needed by openssh-2.9p2-8.7
         libcrypto.so.1   is needed by openssh-server-2.9p2-8.7
         libc.so.6(GLIBC_2.2)   is needed by openssh-server-2.9p2-8.7

 From what I can tell, it requires GLIBC 2.2 to work.

So, I tried to install glibc-2.2.2-10 and glibc-common-2.2.2-10
and got this :

[root at nml i386]# rpm -ivh glibc*
error: failed dependencies:
         glibc > 2.1.3 conflicts with db3-3.1.17-4.6x
         glibc >= 2.1.92 conflicts with rpm-4.0.2-6x
         glibc < 2.2.2 conflicts with glibc-common-2.2.2-10

It seems from the redhat site that the 2 available versions of openssh
requires glibc2.2. So, I am stuck.

I cannot find anything on redhat.com or through google search on how
to get unstuck. It seems to me that RH6.2 cannot work with glibc2.2.

Anybody has any ideas on this one?


More information about the Techtalk mailing list