[techtalk] RE: problem with scp SOLVED

gabrielle gab at gorge.net
Tue Nov 28 19:19:47 EST 2000

Yep--it's fixed.

Jason and Malcolm suggested that scp wasn't in the path on the remote 
machine.  This was indeed the problem, but there's a little more.  I still 
got the "command not found" error when I added the path.  Deja news to the 
rescue:  there is a bug in some versions of OpenSSH (my problem child is 
running OpenSSH-2.1) that makes scp look only in /usr/bin, /bin, and 
/sbin.  Cute, huh?  The bug was supposedly fixed, and then broke again.  I 
symlinked the files and it's working now.  Hooray!

Thanks to everyone for the quick responses.

This was interesting to learn:
Hard to comment about this because you haven't mentioned what client
>you're using to try and connect to these boxes. OpenSSH can talk both
>version 1 and 2 of the protocol. The only time you will get a protocol
>mismatch is if you are using, say, ssh1 to connect to an ssh2 server.
>Hope this helps,

The box I was scping from is actually solaris, running SSH 1.2.22
The linux boxes are SSH 1.3.5 (worked) and OpenSSH-2.1 (didn't work until I 
got the path thing squared away.)  I'm _really_ glad I didn't have to deal 
with installing a different version on any of those boxes right now.

And yes, I plan to do something about the disparate versions and other 
messes while everyone else is on Xmas break in Dec. :)

Again, thanks for all the help!


gab at gorge.net

More information about the Techtalk mailing list