[techtalk] PPP Problems/Questions

Pete Durst pdurst at bigfoot.com
Sat Mar 25 15:44:36 EST 2000


I am having some difficulty establishing a PPP type connection from my 
laptop computer.  Running RH6.1 on an Acer Extensa 393C Laptop, using a 
3Com 3C562D PCMCIA combo card.  The system has lots of disk space, and is 
currently configured with 48MB Ram.  I am able to use the 10BaseT portion 
of the card to connect to the LAN (my home network or otherwise) and using 
WinBlows, I can establish PPP connections to my ISP.  Now for my problem:

I want to be able to setup the laptop to act as a NAT server for a remote 
classroom that I am setting up in a week or so.  I have not tried to get 
PPP working with the laptop before, so have no idea if Linux can do it or 
not.  I do know that Win98 can do the connection, but I am not impressed 
with the "MS" solution.

I have tried several ways of connecting out and in all cases the error I 
get back is not helping me solve my problem:

 From netcfg, I setup a PPP interface, and then try to activate it, and get 
a message stating:
"Failed to activate the /etc/sysconfig/network-scripts/ifcfg-ppp0"

 From kppp, I tried to make a connection, went through the most obvious 
settings, and selected what I thought were the right switches, and when I 
tried to connect (watching the log window), I see the modem getting the 
dialing commands, I see the connection message come back, and then 
immediately I get a message about the "ppp daemon died 
unexpectantly".  Looking at the details, the log file shows that "The 
remote system is required to authenticate itself but I couldn't find any 
secret (password) which would let it use an IP address."

This, of course led me to the /etc/ppp/pap-secrets file, and after reading 
the FAQ and the HOWTO, I think that I have it correctly configured, but 
alas, I still get the same errors.

The next step I took, was to try a manual connection, using minicom.  I 
dialed the number, entered my  name and password, and saw the "PPP Info" 
coming back from the other end.  At this point, I tried to again start the 
ppp daemon, and found that it still gave me the "authentication" error from 
the log file and it caused the connection to drop out.

At this point, I know that the ISP is working, and that I am using the 
right names and passwords, it's just something is not working the way I 
want it to in Linux.  Arggggghhhhh.

Does anybody have any insight into this type of problem?  Any help would be 
much appreciated.



techtalk mailing list
techtalk at linuxchix.org

More information about the Techtalk mailing list