[techtalk] X/windowmaker

Nicole Zimmerman colby at wsu.edu
Wed Mar 22 12:28:08 EST 2000

Allrighty so after some trials and tribulations with X and it's fonts
(everything came up like barcodes), I have X and WindowMaker up and
running on a 2nd computer... video card is an ATI rage 128, using
xserver-svga (X doesn't agree with it being a mach 64, that's fine with
me) on xfree 3.3.6-5.

I have a couple of problems. The first one is just plain irritating... the
fonts in applications are too dang big. Licq and mozilla seem to set their
own font sizes but things like netscape and gaim use whatever the
"default" is (right now it looks about 14 point helvetica to me). I want
it to be smaller, but I can't figure out where to change it.

I installed both xfs and xfstt. In /etc/X11/xfs/config, I changed
default-point-size to = 75 (it was something like 120 before) and my
default-resolutions to 60,60,75,75 (they were 75,75,100,100), but nothing
changed when I restarted X (and I did relogin just to be safe).

I am thinking it might be WindowMaker's fault and not xfs', but I can't
find *anywhere* in WindowMaker's prefs or silly little conf files to
change it. I see /usr/share/WindowMaker/Defaults/WMGLOBAL which says to
use "-*-helvetica-medium-r-normal-*-%d-*-*-*-*-*-*-*" for the SystemFont,
but there is no size in there (it's a %d instead). In
/usr/share/WindowMaker/Defaults/WindowMaker, I tried changing
"DisplayFont" to "-*-helvetica-medium-r-normal-*-10-*-*-*-*-*-*-*" (it was
12). No change there, either.

I'm pretty much stuck... I tried looking over my conf files on my machine
that does display smaller fonts, but I can't figure out where it is. I
know I copied some of the config files from our RH install of WindowMaker
(probably only in my home directory though), but I just can't seem to find
out what's the kicker. The big fonts are nice, but until I can use both of
my monitors/video cards, things are going to have to be a little smaller. 

The second problem happens when I use xterms, usually applications like
pine and pico but sometimes with others. Occasionally when a dialog(ish)
line pops up (which should be at the bottom of the screen above my command
hints), it pops up at the top of my screen (not the xterm window, totally
outside of the window) instead of where it should, or the text doesn't
show up at all. I have seen it several times with ctrl+w (whereis), the
"Search []:" part comes up at the very upper left hand corner of my screen
(atop my clip), but when I type in my response it is held within the
window just fine. 

Sometimes the nifty white (well it's white by default) bar at the top of
pine disappears... sometimes in part, sometimes in full. I have no idea
how that happens, I usually just ctrl+l to refresh and try to ignore it.

I don't know if it's with apps that use ncurses in general, or just with
pine/pico (since I don't use any other ncurses apps it's hard to tell).

any clues/suggestions?


techtalk mailing list
techtalk at linuxchix.org

More information about the Techtalk mailing list