[techtalk] Partial execution of /etc/rc.d/rc.M

Subba Rao subb3 at attglobal.net
Sun Jan 16 00:10:35 EST 2000

On  0, Beverly Guillermo <mezanin at home.com> wrote:
> What are the commands that are not executing?
> On Sat, 15 Jan 2000, Subba Rao wrote:
> > 
> > During the system bootup, the init script /etc/rc.d/rc.M is partially executed.
> > The last 3rd of the file does not get executed. When I run those remaining commands
> > manually, they work fine. Why is that happening?
> > 
> > Assuming there are some hidden characters in the rc.M file, I deleted the problem
> > portion of the file, and retyped them. That did not help either. If there are some
> > hidden characters in a text file, how do I find them out?
> > 

# Start Qmail
if [ -x /etc/rc.d/rc.qmail ]; then
  . /etc/rc.d/rc.qmail start

# Start Samba (a file/print server for Win95/NT machines):
if [ -x /etc/rc.d/rc.samba ]; then
  . /etc/rc.d/rc.samba

# Start GPM mouse server
if [ -x /etc/rc.d/rc.gpm ]; then
  . /etc/rc.d/rc.gpm

# Start System V init scripts for this runlevel
if [ -x /etc/rc.d/rc.sysvinit ]; then
  . /etc/rc.d/rc.sysvinit

# Start the local setup procedure
if [ -x /etc/rc.d/rc.local ]; then
  . /etc/rc.d/rc.local

# All done.

Everything upto (including) Qmail starts. All below that
spews error messages. The messages are something like "command not found" type.
When I run each script manually, they work fine.

Subba Rao
subb3 at attglobal.net

 => Time is relative. Here is a new way to look at time. <=

techtalk at linuxchix.org   http://www.linuxchix.org

More information about the Techtalk mailing list