[techtalk] more netscape woes...

Cathy James cjames at opensite.com
Fri Nov 12 08:27:09 EST 1999

>So what I did the second time around... spawn netscape from an xterm
>instead of using an icon. I believe the icon uses my startx terminal to
>start itself, and obviously since i've been logged into X for 23 days
>that's not going to be updated ;o)

	I should have warned you about that; sorry.  I've
been assuming all along that you were running netscape from
the command line.
	In general, when trying to get any new tool working, it's
best to get it working from the command line first before messing
with other means of starting it.  This helps isolate problems.

>It read off the correct classpath (with all those directories) BUT it
>still didn't find java40.jar. What netscape wants is
>/the/path/to/java40.jar including java40.jar at the end, otherwise it
>just won't find it.

>So I put CLASSPATH=/the/path/to/java40.jar; export CLASSPATH in
>/etc/bashrc (it wouldn't work in /etc/profile for some stupid reason)
>and it worked just fine which I am very glad for.

	I'm glad you got it to work, but this confirms that Netscape
is broken.  This is *not* how CLASSPATH is supposed to work; it's
supposed to be a colon-separated list of *directories* in which 
.jar and .class files can be found.  Netscape isn't playing by
the java rules.
	I just confirmed this on my Sun at work; CLASSPATH
only contains directory paths, not full paths including jar
file names.

>New problem: I don't know if java works. ;o) All the applets I've tried
>to start just don't start. Netscape doesn't complain, the website
>doesn't complain, I just don't see any applets.

	Sorry, I can't help you there.

>Thanks for your help, Cathy :o)

	You're welcome!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://linuxchix.org/pipermail/techtalk/attachments/19991112/936420c2/attachment.xhtml

More information about the Techtalk mailing list