[Techtalk] stuck setting up vpn

mgmonza at sverige.sdf.org mgmonza at sverige.sdf.org
Thu Mar 24 13:22:20 UTC 2022

Hello, all,

Even though this list hasn't been active in a while, I thought I'd give 
this a shot just in case anyone might be able to help.

I just registered for a vpn but can't get it to connect.  It may be that 
this just doens't work server-side:  it's a volunteer, very old linux 
organization with somewhat spotty support.  If not, I was hoping someone 
on this list could see something I'm missing.

I followed their directions to do these steps:

- created theirpptp file in /etc/ppp/peers

- edited the /etc/ppp/chap-secrets file to add their vpn address and my 
password that had been generated by the setup process on the server side

- added a route to the vpn using 'route add'

in sheer desperation, added this from a redhat specific page:
- modprobe nf_conntrack_pptp

but when I tried the next step:

sudo pppd call theirpptp

the connection closed immediately

pinging and traceroute to their vpn work fine.

I'm on a redhat/CentOS platform with selinux and tried this with 
setenforce on and off.  No difference.

varions system error messages are:

The synchronous pptp option is NOT activated
warn[open_inetsock:pppt_callmgr.c:329]: connect:  Connection refused

fatal[callmgr_main:pptp_callmg.c:127]: Could not open control conection to 

One other question:  where should the .ovpn file be saved so that it can 
be found by the programs that need it?

Any help would be very much appreciated.


More information about the Techtalk mailing list