[Techtalk] zoneminder, motion fail on ubuntu 13.10, no /dev/video0

Carla Schroder carla at bratgrrl.com
Sun Feb 2 19:31:36 UTC 2014

hey all,

I swear the more I use computers the more I swear at them. I have a
Foscam FI8905W wireless IP camera. 
Just a nice outdoor cam with its own embedded Web server and wifi so I
can spy on my driveway from any Web browser.


I can log in directly to the Foscam via Web browser, see the live
stream, and access the admin panel from any of my computers and
smartphones. Easy peasey.

So the next step is to set up Zoneminder or Motion for recording and
alerts. There is something batshit screwy with Ubuntu 13.10-- I have an
old Linux Mint 13 installation, and with both Zoneminder and Motion
it's ten minutes from installation to viewing the live stream from the
camera in a browser. But not Ubuntu 13.10.

Motion gives the error message 'Failed to open video
device /dev/video0: No such file or directory' So I created /dev/video0
with good old mknod. Same error message. So I deleted the dratted thing.

I can plug in a USB webcam, which creates /dev/video0, and then Motion
picks up the webcam images. (Cheese and luvcview also display the
webcam stream.) But still no live view, only a series of jpgs in /tmp.

Naturally the motion, Zoneminder, and Ubuntu forums are full of sad
posts with the same problem, but no solution. I'm not even sure where
to start troubleshooting. Bright ideas anyone? Besides going on a
killing spree until all computers are eradicated and we can live happy
and free in an agrarian paradise? 


Ace Linux guru                         +
carlaschroder.com                      +
Everything mortal has moments immortal +

More information about the Techtalk mailing list