[Techtalk] initrd woes

Maria McKinley maria at shadlen.org
Thu Jan 22 00:27:46 UTC 2009

Maria McKinley wrote:
> Greetings,
> I am once again trying to boot a machine over the network, and have made 
> significant progress, but still hung up.
> I've been adding in some debugging statements to my initrd, and here is 
> what I have learned:
> the root directory is mounted over nfs to /root during the nfs script, 
> and remains there through the init-bottom script. One of the parameters 
> it uses is a bit strange, but this does not stop it from being mounted. 
> For completeness, here is what it is using
> nfsmount -o nolock -o ro -o retrans=
> which is very strange, since these are the options I give it:
> "root=/dev/nfs ip=dhcp nfsroot="
> None the less, it seems to mount just fine. The last command in the 
> init-bottom script is
> ln -s $rootmnt/dev /dev
> where $rootmnt is /root. This command runs successfully, determined by 
> adding ls -l /d* to the end of the init-bottom script (it shows a link 
> to /root/dev).
> After the init-bottom script exits, I get:
> mount: mounting /sys on /root/sys failed: No such file or directory
> run-init: /sbin/init: No such file or directory
> [    11.607804] Kernel panic - not syncing: Attempted to kill init!
> I have not been able to determine where initrd goes after it finishes 
> the init-bottom script, so I don't know where the mount command for /sys 
> is given, and not sure how to do any more troubleshooting.
> The /sbin/init is living on /root as of the end of the init-bottom 
> script, and I guess there is suppose to be a link made for this as well, 
> but it looks like this link is never being attempted, maybe because the 
> mount /sys command fails?
> Any ideas? Any experts on initrd out there?
> thanks,
> maria

Never fails that I find some new clue as soon as I hit send. So, I 
realized that /sys really was missing on the exported directory (doh!), 
and added that in, but still go the /sbin/init file missing message and 
kernel panic

Just for S&G, I tried adding this to the end of init-bottom:

nuke /sbin
ln -s $rootmnt/sbin /sbin

But, I still get the /sbin/init missing message, so it must be doing 
more as far as linking and mounting after init-bottom, but I don't know 
where! Any ideas?

thanks again,

More information about the Techtalk mailing list