[Techtalk] Network interfaces in image replication

Joana Botto joana.botto at gmail.com
Sat Nov 8 01:50:09 UTC 2008


I solved the problem by correcting the mac addresses in the files.

I verified the drivers at /etc/modprob.conf

alias eth0 forcedeth
alias eth1 forcedeth
alias eth2 tg3
alias eth3 tg3

and removed the network backup files, eth*.bak

I corrected the mac addresses at /etc/sysconfig/network-scripts/ifcfg-ethX
and at /etc/sysconfig/hwconf I corrected the drivers and the macs.

Best regards,
Joana Botto

On Thu, Nov 6, 2008 at 8:52 PM, Joana Botto <joana.botto at gmail.com> wrote:
> Hi Gayathri,
> The servers are Sun Fire X2200 M2.
> The first two network cards are broadband and the other two are nvidia.
> Best regards,
> Joana Botto
> On Thu, Nov 6, 2008 at 1:40 PM, Gayathri Swaminathan
> <gayathri.swa at gmail.com> wrote:
>> On Wed, Nov 5, 2008 at 3:49 PM, Joana Botto <joana.botto at gmail.com> wrote:
>>> Hi all,
>>> I had to install 16 servers with RHEL 5, I replicated the image using RAID
>>> 1.
>>> The servers are exactly the same and each one has 4 network interfaces.
>>> Some of the serves after a reboot don't have network, the network
>>> interfaces seem to be switched like these eth0 looks like eth2, eth1
>>> is eth3, eth2 is eth1, and eth3 is eth0.
>>> I already tried to comment out the MAC addresses at
>>> /etc/sysconfig/network-scripts/ifcfg-ethX but after a reboot the
>>> network interfaces still appear switched. I also deleted those files
>>> hoping they would be generated but the problem still exists.
>>> Looks like a common problem in image replication. Can somebody give me
>>> a hand please.
>> Hey Joana:
>> What is the hardware branded/custom built?
>> --
>> Gayathri Swaminathan
>> gpgkey: 3EFB3D39
>> Volunteer, FDP

More information about the Techtalk mailing list