[Techtalk] Fwd: User mounting of a NTFS partition

Kathryn Marks kathryn.linux at gmail.com
Thu Jul 10 23:29:04 UTC 2008

And I'll actually send it to the list this time.

It's early :(

---------- Forwarded message ----------
From: Kathryn Marks <kathryn.linux at gmail.com>
Date: Fri, Jul 11, 2008 at 8:27 AM
Subject: Re: [Techtalk] User mounting of a NTFS partition
To: "R. Daneel Olivaw" <linuxchix at r-daneel.com>

On Fri, Jul 11, 2008 at 5:50 AM, R. Daneel Olivaw <linuxchix at r-daneel.com>

> > /dev/sda2               /Data                   vfat    rw,noauto,user  0
> 0
> > /dev/sda1               /Vista                  ntfs    rw,noauto,user  0
> 0
> > So upon reading, I decided to try it ro.  Same outcome.  I tried owner
> > rather than user with the same outcome.  The only way I can mount /Vista
> is
> > as root.  And I really don't want to do that.  It's not mission critical.
> > There isn't *that* much stuff on that partition I would need to access
> (just
> > logs from some software I test) and I can always reboot into Vista. So
> how
> > can I mount /Vista as myself?
> Well, first, the above lines are correct. They should allow you to mount
> the filesystem as a user.

That was my understanding.  But  I'm still fairly new to all of this.  :-)

> Now, I wonder if you are able to mount /Data.

Yes, I can mount /Data as myself.  It is owned by me.  No problems at all.

> If it works, there is some strange bug.

Great.  Just great :)

> If it fails also, I'd check the mount command that should have the
> sticky bit set so the user that runs it gets root for that task.

It's been a while since I dug into permissions with the person who has been
guiding me.  Can you tell me how to do that?

> Besides, are you able to mount anything else "by hand" as an ordinary
> user ?

Like what?  I plug in a thumb drive or my camera and I don't have any
problems with those.  The only other problem I'm having is with ripping a
CD.  It looks like permissions problems (If I'm remembering the conversation
with my guide).  I don't remember off the top of my head how we solved it
last time.  But it was a fix that lasted across reboots.

I should add this is pretty much a brand new install of Fedora 8.  I did it
2 weeks ago.  Not much has been done to it aside from yum updates and a few
bits of software installed (Firefox, GIMP, Open Office)

Thanks for the help.



More information about the Techtalk mailing list