[Techtalk] HP3970 scanner with sane

Rudy Zijlstra rudy at grumpydevil.homelinux.org
Sun Aug 31 16:24:29 UTC 2008

Hi Anne,

Again, all i can do is point in a direction...

One reason is i've never playd yet with scanners and linux.

Anne Wainwright wrote:
> Hi all,
> Trying to get hp scanjet3970 to work
> find 'NEW' driver stuff on SANE site
> all updated
> scanner / usb module loaded
> 'scanner' in /etc/modules  (debian stuff)
> see scanner drivers mentioned in dmesg so all goes ok at startup
> #sane-find-scanner finds it (says (probably) in brackets)*
> #scanimage -L does not find it
> #quiteinsane reports no devices found
> the driver is featured "NEW!" on the sane site, and it has a standalone option (ie I suppose you don't have to worry about updating sane if you have issues with that).
> I have tried both standalone and sane  installations, but doesn't go either way. Oddly, I find nowhere in the readme any way to call the standalone option. Do I misunderstand the use of this, won't it have a name like Xsane or quiteinsane?
> * only when I run as root. it then says 'once you have found the scanner devices adjust access permissions as necessary'. can someone expand please? I see under /dev/usb there are scanner entries (like -scanner0 to -scanner15) which are all set at 666 and owner is root/root
This points to a mis-alignment somewhere. The group owner should be 
'scanner', yet it isn't. These device entries are almost certainly 
dynamic, which means either hotplug or udev creates them. You'll have to 
find out which of the two your system is using. On on older system the - 
now no longer used - hotplug is the most likely. Then find the hotplug 
rules, and modify those to contain the correct group owner for scanner 

Sorry for not being more specific. This is a case where i can recognise 
which corner it is, but have no knowledge of the specific corner ;(



> There is a group called scanner and I am a member of that
> Any help gratefully received.
> Anne

More information about the Techtalk mailing list