[Techtalk] Getting Java running properly on Slackware 10

Tricia Bowen tricia.bowen at gmail.com
Mon Oct 8 13:38:27 UTC 2007

You can try these commands to locate the java binaries:
$ which javac
$ locate javac

Once you have the location of the binary then test your program with
$ /xxx/xxx/xxx/javac HelloWorld.java

If you have a package line in your code then do
$/xxx/xxx/xxx/javac packageDir/HelloWorld.java

If everything works then add the location of the java binary to your .bashrc


On 10/8/07, turtle <dreaded.night.turtle at gmail.com> wrote:
> I'm an extreme n00b to linux so this question may not even make sense as
> I'm
> not clear on what I'm asking.
> I've got Slackware 10 on my laptop.  When it was installed, I deliberately
> chose not to use a dual boot with Windows because I did not want to always
> go running back to what I know when I run into difficulties.  I've never
> used linux before so I'm learning trial by fire how to make stuff work.
> This means that not everything on my laptop functions, but I'm learning at
> a
> fairly fast pace so it's working well for me.  Unfortunately, I've run
> into
> an issue where I need to have something working properly for
> time-sensitive
> school assignments, and I haven't been able to get it working on my own.
> All the research I've done into this has lead me to believe that either I
> have an interesting problem, or I just haven't been searching properly for
> my answer because I'm forming my question wrong.
> I'm taking a course in Java.  My friend set me up with an ssh id to get
> into
> his server where he installed Java properly and I can try to run command
> line programs.  Unfortunately, my course is using JOptionPane exclusively
> for inputing data, so while I can write up my programs in vim and use
> javac
> to see if they compile, I have not been able to actually test if the
> programs run properly.
> I've tried installing Java on my machine but have been unsuccessful.  I
> asked a friend for help and he tried to install it on my laptop.
> Unfortunately, although he believes it is successfully installed, I'm not
> able to use it.  When I create a .java file, save it to my desktop, and
> try
> to compile it, the response I get is "javac: command not found"  When I
> asked the friend who said he installed it why it was doing this, he said:
> "It would "automaticly" set it up if i had added java to your command
> path,
> which, if you remeber, I was perlexed about because your distro did not
> include certain bash files in your home directory that would allow me to
> set
> the path."
> Has anyone ever experienced this difficulty in Slackware?  Does anyone
> know
> where I might find a step by step walkthrough on how to properly set the
> path/associate the files so that I can get Java working on my Slackware 10
> machine?
> I realize I may be asking my question wrong.  If so, please let me know
> how
> I can provide more accurate questions to get what I need.  Realistically,
> I
> need to "make it go" and understanding why it's doing what it is doing is
> not as important as fixing it in a timely fashion.  It's driving me nuts
> that I can test for compilation but am unable to see if the programs I'm
> writing will run until I email them to myself and then drive across the
> city
> to the Unviersity to test them in the labs there.
> Any help you can send my way would be most appreciated.
> ~Daria
> _______________________________________________
> Techtalk mailing list
> Techtalk at linuxchix.org
> http://mailman.linuxchix.org/mailman/listinfo/techtalk


More information about the Techtalk mailing list