[Techtalk] "bind to reserved port" error

David Sumbler david at aeolia.co.uk
Tue Mar 27 14:42:57 UTC 2007

On Tue, 2007-03-27 at 15:09 +0200, Wim De Smet wrote:
> On 3/27/07, David Sumbler <david at aeolia.co.uk> wrote:
> > I am running Ubuntu 6.10, and have plptools installed.  This is a
> > collection of programs for connecting to a Psion hand-held computer.  I
> > have used it before under Fedora.
> >
> > In order to connect to the Psion, which is connected to /dev/ttyS0, a
> > daemon called 'ncpd' is run.  This seems to be working
> > fine: /var/log/daemon reports:
> >
> > daemon started. Listening at using device /dev/ttyS0
> > Connected with a S5 at 115200baud
> >
> > (S5 is the variety of Psion computer that I have.)
> >
> > In order to read the files on the Psion, I then have to run another
> > daemon called 'plpnfsd'.  Although it prints an encouraging message on
> > the screen, it actually exits immediately.  The log file reports:
> >
> > connected, status is 0
> > bind to reserved port: Permission denied
> >
> > I have tried running ncpd and plpnfsd using an arbitrary different port,
> > but with exactly the same results.
> >
> > My firewall settings seem to be fine, so far as I can tell.
> >
> > Can anyone shed any light on why the port is reported as "reserved"?
> All ports under 1024 are reserved, this means only root can bind to
> them. You probably need to convince this second daemon to use one of
> the ports above 1024, or run it as root.

But the port being used is 7501.  I have also tried other arbitrarily
chosen ports - e.g. 8513 - with the same result.

If I run plpnfsd as root, it appears to hang for a couple of minutes,
but it does eventually make the connection successfully, and goes into
the background.

How can I persuade it that port 7501 is not "reserved"?


David Sumbler <david at aeolia.co.uk>

More information about the Techtalk mailing list